HDU 1711 Number Sequence(kmp专题)

时间:2023-01-03 17:38:59
A - Number Sequence
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 
 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
 

Sample Input

 
       
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output

 
       
6 -1
 

模板题不解释
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<limits.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n,m;
int p[1000005],a[1000005],b[10005];
int ans;
void print()
{
	p[1]=0;
	int  i,j=0;
	for(i=2;i<=m;i++)
	{
		while(j>0 && b[j+1]!=b[i])
			j=p[j];
		if(b[j+1]==b[i])
			j++;
		p[i]=j;
	}
}
void kmp()
{
	int i,j=0;
	for(i=1;i<=n;i++)
	{
		while(j>0 && b[j+1]!=a[i])
			j=p[j];
		if(a[i]==b[j+1])
			j++;
		if(j==m)
		{
			ans=i;
			return ;
		}
	}
}
int  main()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		ans=-1;
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(j=1;j<=m;j++)
			scanf("%d",&b[j]);
		print();
		kmp();
		if(ans==-1)
		printf("-1\n");
		else
			printf("%d\n",ans-m+1);
	}
}