HDU1711 Number Sequence KMP基础

时间:2023-01-03 17:48:47
Number Sequence
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 
 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
 

Sample Input

 
     
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output

 
     
6 -1
题意:输出b序列 在a序列中匹配到的第一个位置。
唯一要注意的是KMP的出的结果是末尾的位置 那么结果减去b的长度加1就是答案了
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxm=1000005;
int p[maxm],a[maxm],b[maxm],n,m;
void find();
int kmp();
int main()
{
	int i,j,k,sum,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);
		find();
		printf("%d\n",kmp()+1);
	}
	return 0;
}
void find()
{
	int i,j=-1;
	p[0]=-1;
	for(i=1;i<m;i++)
	{
		while(j>=0 && b[j+1]!=b[i])
			j=p[j];
		if(b[j+1]==b[i])
			j++;
		p[i]=j;
	}
}
int kmp()
{
	int i,j=-1;
	for(i=0;i<n;i++)
	{
		while(j>=0 && b[j+1]!=a[i])
			j=p[j];
		if(b[j+1]==a[i])
			j++;
		if(j==m-1)
			return i-m+1;
	}
	return -2;
}