HDU1711 Number Sequence(字符串匹配KMP)

时间:2023-01-03 17:39:29

题目:

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26616    Accepted Submission(s): 11229


Problem Description Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 
Sample Output
6
-1
 
Source HDU 2007-Spring Programming Contest  
Recommend lcy   |   We have carefully selected several similar problems for you:  1358 3336 1686 3746 1251   
Statistic |  Submit |  Discuss |  Note
思路:

KMP算法模板题,求子串首次出现的位置

代码:

#include<cstdio>
#include<cstring>
#include<cctype>
#include<string>
#include<set>
#include<iostream>
#include<stack>
#include<cmath>
#include<queue>
#include<vector>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define mod 10000007
#define debug() puts("what the fuck!!!")
#define N 1000020
#define ll longlong
using namespace std;
int a[N],b[10020],nex_t[10020];
int n,m;
void get_next()//构建next数组
{
int j=0,k=-1;
nex_t[0]=-1;
while(j<m)
{
if(k==-1||b[j]==b[k])
nex_t[++j]=++k;
else
k=nex_t[k];
}
}
int KMP_index()//返回首次出现位置
{
int i=0,j=0;
get_next();
while(i<n&&j<m)
{
if(j==-1||a[i]==b[j])
{
i++,j++;
}
else
j=nex_t[j];
}
if(j==m)
return i-m+1;
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<m;i++)
scanf("%d",&b[i]);
printf("%d\n",KMP_index());
}
return 0;
}