HDU1711 Number Sequence (KMP 模板)

时间:2023-01-03 17:39:23
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 
InputThe first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
OutputFor each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
#include<iostream>
#include<memory.h>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
//1000005
int f[1000005];int n,N,M;
int P[1000005],T[1000005],s3[1000005]; 
int len1,len2;

void getnext(){
	 int i = 0, j = -1;  
    f[0] = -1;  
    while (i < M) {  
        if (j == -1 || P[i] == P[j]) {  
            i++;  
            j++;  
            f[i] = j;  
        } else  
            j = f[j];  
    }  
}
int kmp() {  
    int i = 0, j = 0;  
    
    getnext();  
    while (i < N) {  
        if (j == -1 || T[i] == P[j]) {  
            i++;  
            j++;  
        } 
		else  
            j = f[j];  
            
        if (j == M) {  
            return i-j+1; 
        }  
        
    }   
	return -1;
    
}  
int main(){
	
	cin>>n;
	while(n--){
	memset(f,0,sizeof(f));  	
    cin>>N>>M;
    for(int i=0;i<N;i++){
    	cin>>T[i];
	}
	for(int i=0;i<M;i++){
    	cin>>P[i];
	}

	  printf("%d\n",kmp());  
	
	}
	
		
	return 0;
}
一开始把匹配的字符串定义成了char,无限WA。。。还有数组不够大会TLE