1065. A+B and C (64bit) (20)

时间:2022-04-04 04:17:40

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        long long a,b,sum=0,c;
        cin>>a>>b>>c;
        sum=a+b;
        if(a>0 && b>0 && sum<0)
        {
            printf("Case #%d: true\n",i+1);
        }
        else if(a<0&&b<0&&sum>=0)
        {
            printf("Case #%d: false\n",i+1);
        }
        else if(sum>c)
        {
            printf("Case #%d: true\n",i+1);
        }
        else
        {
            printf("Case #%d: false\n",i+1);
        }
    }
    return 0;
}