PAT 1065. A+B and C (64bit) (20)

时间:2022-09-01 09:56:08

1065. A+B and C (64bit) (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

本题考察64位加减法。用long long int就可以进行计算,但是要考虑两个溢出的情况:

1) a>0,b>0,然而a+b<=0

2)a<0, b<0,然而a+b>=0

这是加法中会出现的两种溢出,本题中的处理很简单,针对第一种情况答案就是true,针对第二种情况答案就是false。(因为一个大到溢出,一个小到溢出,而c本身必定是不会溢出的)。代码如下:  

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <cstring>
using namespace std;

int main(void)
{
	int N,i;
	cin>>N;
	for(i=1;i<=N;i++)
	{
		long long int a,b,c,d;
		cin>>a>>b>>c;
		d=a+b;
		if(a>0&&b>0&&d<=0)
			cout<<"Case #"<<i<<": true"<<endl;
		else if(a<0&&b<0&&d>=0)
			cout<<"Case #"<<i<<": false"<<endl;
		else
		{
			if(d>c)
				cout<<"Case #"<<i<<": true"<<endl;
			else
				cout<<"Case #"<<i<<": false"<<endl;
		}
	}
	return 0;
}