pat 1065. A+B and C (64bit)

时间:2022-04-04 04:18:04

原题链接:https://www.patest.cn/contests/pat-a-practise/1065


          1065. A+B and C (64bit) (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false

主要对于溢出情况做特殊判断


// pat_A+B and C (64bit).cpp : 定义控制台应用程序的入口点。
//

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
typedef long long ll;

ll a, b, c, res;

int main(int argc, char* argv[])
{
	int T,cas=1;
	scanf("%d", &T);
	while (T--)
	{
		int flag=1;
		scanf("%lld%lld%lld", &a, &b, &c);
		res = a + b;
		if (a < 0 && b < 0 && res>=0)//注意res==0也要包括
			flag = 0;
		else if (a>0 && b > 0 && res <=0)//写成res< =0就错??
			flag = 1;
		else if (res > c)
			flag = 1;
		else
			flag = 0;
		printf("Case #%d: %s\n", cas++, flag == 1 ? "true" : "false");
	}
	return 0;
}