Card Game Cheater(二分图匹配+匈牙利算法+模拟)

时间:2023-01-16 06:28:20

Problem Description Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 
Input There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 
Output For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 
Sample Input
3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D
 
Sample Output
1
1
2
 
Source Northwestern Europe 2004

题解:

俩哥们打牌,他们都有n张牌,第二个哥们想至少能赢第一个哥们几次,一个模拟+二分图匹配

将题目给的数据转化成数字有点麻烦,然后匈牙利算法套的去就好了,这里我用了邻接表的方法写匈牙利算法

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<deque>
#define M (t[k].l+t[k].r)/2
#define lson k*2
#define rson k*2+1
#define ll long long
using namespace std;
int n;
int getnum(char c)//牌大小
{
if(c=='T')
return 10;
else if(c=='J')
return 11;
else if(c=='Q')
return 12;
else if(c=='K')
return 13;
else if(c=='A')
return 14;
else
return c-'0';
}
int getcent(char c)//花色
{
if(c=='C')
return 1;
else if(c=='D')
return 2;
else if(c=='S')
return 3;
else
return 4;
}
int a[105];//存第一个哥们的牌
int b[105];//存第二个哥们的牌
int vis[105];//遍历数组
int used[105];//存比第一个哥们第i张牌还大的第二个哥们的牌的标号
int num[105];//存第二个哥们第i张牌比第一个哥们的牌大的有几张
int p[105][105];//存第二个哥们比第一个哥们的牌大的有哪些标号,hhhh有点搞笑的注释
int find(int u)//匈牙利算法求
{
int i;
for(i=0;i<num[u];i++)//邻接表写法
{
if(!vis[p[u][i]])
{
vis[p[u][i]]=1;
if(!used[p[u][i]]||find(used[p[u][i]]))
{
used[p[u][i]]=u;
return 1;
}
}
}
return 0;
}
int main()
{
int i,j,k,m,test;
char s[10];
scanf("%d",&test);
while(test--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%s",s);
a[i]=getnum(s[0])*10+getcent(s[1]);//获得该牌的值
}
for(i=1;i<=n;i++)
{
scanf("%s",s);
b[i]=getnum(s[0])*10+getcent(s[1]);
}
memset(num,0,sizeof(num));
memset(used,0,sizeof(used));
for(i=1;i<=n;i++)//遍历一遍用邻接表存起来
{
for(j=1;j<=n;j++)
{
if(b[i]>a[j])
{
p[i][num[i]]=j;
num[i]++;
}
}
}
int ans=0;
for(i=1;i<=n;i++)//求最大匹配数
{
memset(vis,0,sizeof(vis));
if(find(i))
ans++;
}
printf("%d\n",ans);
}
return 0;
}