2017上海金马五校程序设计竞赛 E:Find Palindrome

时间:2022-08-09 19:19:42

Time Limit: 1 s

Description

Given a string S, which consists of lowercase characters, you need to find the longest palindromic sub-string.
A sub-string of a string S  is another string S'  that occurs "in" S. For example, "abst" is a sub-string of "abaabsta". A palindrome is a sequence of characters which reads the same backward as forward.

 

Input

There are several test cases. Each test case consists of one line with a single string S (1 ≤ || ≤ 50).

 

Output

For each test case, output the length of the longest palindromic sub-string.

 

Sample Input

sasadasa
bxabx
zhuyuan

 

Sample Output

7
1
3

题目意思:

给你一串字符,让你找出其中最长的回文子串长度。

解题思路:

首先先看字符串,对于第 i 个字符str[i],如果回文子串有奇数个字符,那么以 i 为中心向左向右扩展,直到发现对称位置字符不相等,如果扫过X个字符,那么回文子串长度为2*X+1.

如果回文子串有偶数个字符,对于第 i 个字符str[i]在最接近对称轴的左边。对于这种情况我们要从第 i 个位置开始扫描,并与第 i+1 个位置字符进行比较,在向左向右扩展,直到对称位置字符不相同为止。如果扫过了X个字符,那么回文子串长度为2*X。



#include<iostream>  
#include<stdio.h>
#include<algorithm>
#include<string.h>
#define INF 999999
using namespace std;
int main()
{
int maxlen,i,j,len; ///最长对称子串长度。
char str[1003];
while(gets(str))
{
maxlen = 0;
len = strlen(str);
for(i = 0; i < len; i++)
{
///考虑是i是奇数串的中心,以i为中心,同时往左往右扩展
for(j = 0; i-j>=0&&i+j<=len; j++)
{
if(str[i-j]!=str[i+j])
break;
if(2*j+1>maxlen)
maxlen = 2*j+1;
}
///i是偶数串的中心
for(j = 0; i-j>=0&&i+j+1<len;j++)
{
if(str[i-j]!=str[i+j+1])
break;
if(2*j+2>maxlen)
maxlen = 2*j+2;
}
}
printf("%d\n",maxlen);
}
return 0;
}