POJ 1850 Code

时间:2021-11-16 11:12:27
Code
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 9961   Accepted: 4768

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2
...
z - 26
ab - 27
...
az - 51
bc - 52
...
vwxyz - 83681
...

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input

The only line contains a word. There are some constraints:
• The word is maximum 10 letters length
• The English alphabet has 26 characters.

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source


输出某个str字符串在字典中的位置,由于字典是从a=1开始的,因此str的位置值就是 在str前面所有字符串的个数 +1
规定输入的字符串必须是升序排列。不降序列是非法字符串
不要求用循环输入去输入若干组字符串,但若输入非法字符串则输出0,且结束程序,这是和POJ1496最猥琐的区别,很多同学只注意到规定str的长度不同,以为把str数组长度改一下直接复制就能AC再多刷一题了,殊不知老是WA却找不到原因,大概就是这里出问题了
本题Str最长为10个字符
解题思路:
组合数学题,不知道为什么会被归类到递推数学,可能是因为杨辉三角和组合数之间的关系。。。
第一步当然首先判断输入的str是否是升序序列
若符合第一步,则首先计算比str长度少的所有字符串个数
假设str为 vwxyz ,则其长度为5
那么
POJ 1850 Code
然后就是关键了,长度为2的字符串,根据开头字母不同,就有25种不同情况,编程去处理是很困难的。这里必须要用数学方法去处理。
POJ 1850 Code
所以用一个简单的循环就能计算出 比str长度少的所有字符串个数 了,这就是数学的威力,把受限的取法转换为不限制的取法
第三步,就是求长度等于str,但值比str 小的字符串个数
这个看我程序的注释更容易懂,所以这里就不再啰嗦了,值得注意的是这步我同样利用了公式(1),所以如果看到某些地方取字母的时候看上去好像没有遵守“升序规则”,本来要限制取字母的地方却没有限制,那一定是用公式(1)变换了
第四步,把前面找到的所有字符串的个数之和再+1,就是str的值
之所以+1,是因为此前的所有操作都只是找str之前的字符串,并不包括str本身
然后到了最后,剩下一个问题就是怎样得到每一个 的值,这个我发现很多同学都是利用打表做的,利用的就是 组合数 与 杨辉三角 的关系(建立一个二维数组C[n]
就能看到他们之间关系密切啊!区别就是顶点的值,杨辉三角为1,组合数为0)
其实这个“关系”是有数学公式的
POJ 1850 Code

这是看的别人的讲解,下面是我的想法:

长度为1时:从26个字母中选一个 c[26][1];

长度为2时:从26个字母选两个c[26][2];

.......

同样的思想计算长度为len,值比str小的数


AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;

char str[20];
int c[27][27];
void yanghui()
{
    memset(c,0,sizeof(c));
    c[0][0]=1;
    for(int i=1;i<=26;i++)
    {
        for(int j=0;j<=i;j++)
        {
            c[i][j]=c[i-1][j-1]+c[i-1][j];
        }
    }
    c[0][0]=0;
}
int main()
{
    int len,sum;
    yanghui();
    //cout<<c[26][2]<<endl;
    //cout<<26+(25*13)+1<<endl;
    while(~scanf("%s",str))
    {
        len=strlen(str);
        for(int i=0;i<len-1;i++)//判断是否符合升序要求
        {
            if(str[i]>=str[i+1])
            {
                cout<<0<<endl;
                return 0;//循环输入时一定注意,当下情况不能继续输入
            }
        }


        //计算长度比str小的字符串的个数
        sum=0;
        for(int i=1;i<len;i++)
            sum+=c[26][i];
        //计算长度等于len,但值比str小的字符串个数
        char last='a';
        for(int i=0;i<len;i++)//i为str的指针,对每一个位置枚举 
        {
            for(char j=last;j<str[i];j++)//根据升序规则,当前位置值比str小的数
            {
                sum+=c['z'-j][len-i-1];
            }
            last=str[i]+1;
        }
        cout<<sum+1<<endl;
    }

    return 0;
}