POJ 2109 Power of Cryptography(数论)

时间:2023-02-02 15:02:06
Power of Cryptography
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12219   Accepted: 6251

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n th. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10 101 and there exists an integer k, 1<=k<=10 9 such that k n = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

Source

解题思路:训练计划上说这是一道贪心的题目,想了好久也没有想出办法,就去Discuss看了看,结果用下面的方法就能AC,因为k n = p,所求的是n,k = p的1/n的次方;
代码如下:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main()
{
double n, p;
while (scanf("%lf%lf", &n, &p) != EOF)
{
printf("%.0lf\n", pow(p, 1.0 / n));
}
return 0;
}