HDU3613 Best Reward 3连发之扩展KMP

时间:2023-01-03 16:43:05

题目链接:HDU3613

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1420    Accepted Submission(s): 576


Problem Description After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 
Input The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000. 

 
Output Output a single Integer: the maximum value General Li can get from the necklace.   
Sample Input
2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac
 
Sample Output
1
6
 
Source 2010 ACM-ICPC Multi-University Training Contest(18)——Host by TJU   
Recommend lcy   |   We have carefully selected several similar problems for you:  3618 3620 3614 3615 3616 
题目分析:这次采用扩展KMP求解,扩展KMP用来求最大公共前缀。其中extand[i]储存主串从i开始与模式串最大公共前缀。由此可知(以主串为正向,模式串为逆向为例)当extand[len-i]=i时代表从s1[i]~s1[len-1]=s2[0]~s2[len-i-1]=s1[len-1]~s1[i]肯定是回文串了。当主串与模式串互换时同样成立。之后统计求最大值就可以了。

注意要预处理下所有可能的前缀值的和否则可能会超时。第二要注意必须要分一次,不可以不分。比如串长度为1就可以直接输出0了。

//
// main.cpp
// HDU3613b
//
// Created by teddywang on 16/3/21.
// Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 500000+10
using namespace std;
int len,n,m;
char s1[maxn],s2[maxn];
int v[27];
int nexts[maxn],ex1[maxn],ex2[maxn],sum[maxn];

void get_extand(char *s,char *t,int *next,int *extand)
{
int j=0;
nexts[0]=len;
while(t[j+1]==t[j] &&j+1<len) j++;
nexts[1]=j;
int a=1;
for(int i=2;i<len;i++)
{
int p=nexts[a]+a-1;
int L=nexts[i-a];
if(p+1>L+i) nexts[i]=L;
else
{
int q=p-i+1;
j=max(0,q);
while(i+j<len&&t[i+j]==t[j]) j++;
nexts[i]=j;
a=i;
}
}
j=0;
while(s[j]==t[j]&&j<len) j++;
extand[0]=j;
a=0;
for(int i=1;i<len;i++)
{
int p=extand[a]+a-1;
int L=nexts[i-a];
if(p+1>L+i) extand[i]=L;
else
{
int q=p-i+1;
j=max(0,q);
while(i+j<len&&s[i+j]==t[j]) j++;
extand[i]=j;
a=i;
}
}
}

int main()
{
cin>>m;
while(m--)
{
for(int i=0;i<26;i++)
scanf("%d",&v[i]);
scanf("%s",s1);
len=strlen(s1);
if(len==1) {
cout<<0<<endl;
continue;
}
sum[0]=0;s2[len]=0;
for(int i=0;i<len;i++)
{
sum[i+1]=sum[i]+v[s1[i]-'a'];
s2[i]=s1[len-i-1];
}
get_extand(s1,s2,nexts,ex1);
get_extand(s2,s1,nexts,ex2);
int ans=-100000;
for(int i=1;i<len;i++)
{
int temp=0;
if(ex1[len-i]==i) temp+=sum[len]-sum[len-i];
if(ex2[i]+i==len) temp+=sum[len-i];
if(ans<temp) ans=temp;
}
cout<<ans<<endl;
}
}