UVA 10285 - Longest Run on a Snowboard (记忆化搜索+dp)

时间:2022-09-18 23:32:55

Longest Run on a Snowboard

Input: standard input

Output: standard output

Time Limit: 5 seconds

Memory Limit: 32 MB

Michael likes snowboarding. That's not very surprising, since snowboarding is really great. The bad thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when you've reached the bottom of the hill you have to walk up again or wait for the ski-lift.

Michael would like to know how long the longest run in an area is. That area is given by a grid of numbers, defining the heights at those points. Look at this example:

 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

One can slide down from one point to a connected other one if and only if the height decreases. One point is connected to another if it's at left, at right, above or below it. In the sample map, a possible slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-...-3-2-1, it would be a much longer run. In fact, it's the longest possible.

Input

The first line contains the number of test cases N. Each test case starts with a line containing the name (it's a single string), the number of rows Rand the number of columns C. After that follow R lines with C numbers each, defining the heights. R and C won't be bigger than 100N not bigger than 15 and the heights are always in the range from 0 to 100.

For each test case, print a line containing the name of the area, a colon, a space and the length of the longest run one can slide down in that area.

Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

Feldberg: 7
Spiral: 25
题目分析:从一个点可以向它周围的四个点滑,求一条最长的递减路径,输出最长路径的长度。
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b;
int r,c;
int map[105][105],dp[105][105];
int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
int dfs(int x,int y)
{
int &ans=dp[x][y]; /*引用dp[x][y]*/
if(ans)
return ans;
bool flag=false;
for(int i=0;i<4;i++)
{
int nx=x+dir[i][0];
int ny=y+dir[i][1];
if(nx>=0&&ny>=0&&nx<r&&ny<c&&map[nx][ny]<map[x][y])
{
ans=max(ans,dfs(nx,ny)+1);
flag=true;
}
}
if(!flag) return 1;
return ans;
}
int main()
{
char str[100];
int i,j,MAX,cas;
scanf("%d",&cas);
while(cas--)
{
scanf("%s%d%d",str,&r,&c);
for(i=0;i<r;i++)
for(j=0;j<c;j++)
scanf("%d",&map[i][j]);
MAX=0;
memset(dp,0,sizeof(dp));
for(i=0;i<r;i++)
for(j=0;j<c;j++)
MAX=max(MAX,dfs(i,j));
printf("%s: %d\n",str,MAX);
}
return 0;
}

其中,int &ans=dp[x][y]是对dp[x][y]的引用,用ans的值代替dp[x][y]的值,对ans的操作就相当于对dp[x][y]的操作,ans的值改变以后dp[x][y]的值也会变化。

UVA 10285 - Longest Run on a Snowboard (记忆化搜索+dp)的更多相关文章

  1. UVA 10285 Longest Run on a Snowboard&lpar;记忆化搜索)

    Problem C Longest Run on a Snowboard Input: standard input Output: standard output Time Limit: 5 sec ...

  2. UVa 10285 Longest Run on a Snowboard - 记忆化搜索

    记忆化搜索,完事... Code /** * UVa * Problem#10285 * Accepted * Time:0ms */ #include<iostream> #includ ...

  3. UVa 10285 Longest Run on a Snowboard【记忆化搜索】

    题意:和最长滑雪路径一样, #include<iostream> #include<cstdio> #include<cstring> #include <c ...

  4. UVa 10285 - Longest Run on a Snowboard

    称号:给你一个二维矩阵,找到一个点.每一个可以移动到的位置相邻的上下,求最长单调路径. 分析:贪婪,dp.搜索. 这个问题是一个小样本,我们该怎么办. 这里使用贪心算法: 首先.将全部点依照权值排序( ...

  5. UVA - 10285 Longest Run on a Snowboard (线性DP)

    思路:d[x][y]表示以(x, y)作为起点能得到的最长递减序列,转移方程d[x][y] = max(d[px][py] + 1),此处(px, py)是它的相邻位置并且该位置的值小于(x, y)处 ...

  6. UVA - 10285 Longest Run on a Snowboard(最长的滑雪路径)(dp---记忆化搜索)

    题意:在一个R*C(R, C<=100)的整数矩阵上找一条高度严格递减的最长路.起点任意,但每次只能沿着上下左右4个方向之一走一格,并且不能走出矩阵外.矩阵中的数均为0~100. 分析:dp[x ...

  7. 记忆化搜索&lpar;DP&plus;DFS&rpar; URAL 1183 Brackets Sequence

    题目传送门 /* 记忆化搜索(DP+DFS):dp[i][j] 表示第i到第j个字符,最少要加多少个括号 dp[x][x] = 1 一定要加一个括号:dp[x][y] = 0, x > y; 当 ...

  8. UVA 825 Walking on the Safe Side&lpar;记忆化搜索&rpar;

      Walking on the Safe Side  Square City is a very easy place for people to walk around. The two-way ...

  9. uva 10581 - Partitioning for fun and profit&lpar;记忆化搜索&plus;数论&rpar;

    题目链接:uva 10581 - Partitioning for fun and profit 题目大意:给定m,n,k,将m分解成n份,然后依照每份的个数排定字典序,而且划分时要求ai−1≤ai, ...

随机推荐

  1. flash&lowbar;header&period;S &lpar; freescale imx6 board&rpar;

    /* * Copyright (C) 2011-2012 Freescale Semiconductor, Inc. * * This program is free software; you ca ...

  2. baguetteBox&period;js响应式画廊插件&lpar;纯JS&rpar;

    baguetteBox.js baguetteBox.js 是一个简单和易于使用lightbox纯JavaScript脚本,拥有图像放大缩小并带有相应的CSS3过度,并能在触摸屏等设备上完美展示. D ...

  3. ssh sftp scp命令

    scp local_file remote_username@remote_ip:remote_folder 或者 scp local_file remote_username@remote_ip:r ...

  4. 序列化Color对象

    如下: public class Class2 { [XmlIgnore] public Color Color1 { get { return color1; } set { color1 = va ...

  5. Druid 简单介绍

    官方网址:http://code.alibabatech.com/wiki/display/Druid/Home 1.什么是Druid Druid首先是一个数据库连接池.Druid是目前最好的数据库连 ...

  6. Struts2--课程笔记2

    动态方法调用(在请求的时候,再明确具体的响应方法,配置的时候不明确): LoginAction类中有两个方法some和second 1. 动态方法的调用(修改常量struts.enable.Dynam ...

  7. List转换成JSON对象报错(二)

    List转换成JSON对象 1.具体报错如下 Exception in thread "main" java.lang.NoClassDefFoundError: org/apac ...

  8. npm错误:Error&colon; listen EADDRNOTAVAIL

    错误 Error: listen EADDRNOTAVAIL 127.0.0.1:8080 有两种情况 8080端口被绑定了 地址错误 Error: getaddrinfo ENOTFOUND 域名错 ...

  9. 【java规则引擎】《Drools7&period;0&period;0&period;Final规则引擎教程》第4章 4&period;2 lock-on-active

    转载至:https://blog.csdn.net/wo541075754/article/details/75208955 lock-on-active 当在规则上使用ruleflow-group属 ...

  10. Junit Test 的时候出错java&period;lang&period;IllegalStateException&colon; Failed to load ApplicationContext

    问题原因 JDK1.8    spring版本3.2.0RELEASE JDK和spring版本不兼容 解决方法 1.降低JDK版本到1.7 2.将spring的版本升级到4.0.0RELEASE或者 ...