Binary Numbers(HDU1390)

时间:2022-09-18 07:53:14

Binary Numbers

点我

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3820    Accepted Submission(s):
2321

Problem Description
Given a positive integer n, find the positions of all
1's in its binary representation. The position of the least significant bit is
0.

Example

The positions of 1's in the binary representation
of 13 are 0, 2, 3.

Task

Write a program which for each data
set:

reads a positive integer n,

computes the positions of 1's in
the binary representation of n,

writes the result.

Input
The first line of the input contains exactly one
positive integer d equal to the number of data sets, 1 <= d <= 10. The
data sets follow.

Each data set consists of exactly one line containing
exactly one integer n, 1 <= n <= 10^6.

Output
The output should consists of exactly d lines, one line
for each data set.

Line i, 1 <= i <= d, should contain increasing
sequence of integers separated by single spaces - the positions of 1's in the
binary representation of the i-th input number.

Sample Input
1
13
Sample Output
0 2 3
 #include <iostream>
using namespace std;
int main(int argc, char const *argv[])
{
int T;
cin>>T;
while(T--)
{
int n,i=,j,k,flag=;
cin>>n;
while(n)
{
if(n%==)
{
cout<<i;
if(n>=)
cout<<' ';
}
i++;
n/=;
}
cout<<endl;
}
}