【HDU】-1513-Palindrome(LCS,模板+滚动数组)

时间:2022-09-10 08:18:14

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5237    Accepted Submission(s): 1793


Problem Description A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 
Input Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 
Output Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 
Sample Input
5
Ab3bd
 
Sample Output
2
  题意:给定一个字符串问至少需要添加多少个字符使其变成回文(正着读倒着读一样)。 题解:其实就是求 n - (字符串本身和他的逆串的最长公共子序列的长度)

这里还用到了一个滚动数组,因为 dp[5010][5010] Memory Limit Exceeded

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(a,b) memset(a,b,sizeof(a))
int dp[2][5010];
int main()
{
int n;
char a[5010],b[5010];
while(~scanf("%d",&n))
{
scanf("%s",a);
for(int i=0;i<n;i++)
b[n-i-1]=a[i];
for(int i=0;i<=n;i++)
dp[i][0]=0;
for(int i=0;i<=n;i++)
dp[0][i]=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(a[i-1]==b[j-1])
dp[i%2][j]=dp[(i-1)%2][j-1]+1;
else
dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
}
}
printf("%d\n",n-dp[n%2][n]);
}
return 0;
}