1045 - Digits of Factorial
Time Limit: 2 second(s) Memory Limit: 32 MB Description Factorial of an integer is defined by the following functionf(0) = 1f(n) = f(n - 1) * n, if(n > 0)
So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.
In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.
Input
Input starts with an integer T (≤ 50000), denoting the number of test cases.
Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.
Output
For each case of input you have to print the case number and the digit(s) of factorial n in the given base.
Sample Input
5
5 10
8 10
22 3
1000000 2
0 100
Sample Output
Case 2: 5
Case 3: 45
Case 4: 18488885
Case 5: 1
题意:求出n!用base进制表示有多少位;
思路:n=10^a*10^b->log(10,n)=a+b ,a是整数表示n在10进制下10的最高次方,b是小数,10^b表示剩余的数的大小,a+1就是n在10进制下的长度了,在base进制下:log(base,N!)={ln(1)+ln(2)+ln(3)+....+ln(N)}/ln(base), 在处理时预先处理一下 a[n]表示ln(1)+..ln(n);
失误:没有想到还能这样写,看来对数和阶乘还是紧密行相连的,阶乘取对数就成累加了,还能表示一个数的最高次方;
代码如下:
#include<cstdio>
#include<math.h>
double a[1000000+99];
void init()//区间值打个表表示
{
int i=0; a[1]=0.0;
for(i=1;i<=1000000+12;++i)
{
double tem=i*1.0;
a[i]=a[i-1]+log(tem);
}
}
int main()
{
int T,N,base,Kase=0;
init();
scanf("%d",&T);
while(T--)
{
scanf("%d %d",&N,&base);
int ans=(int)(a[N]/(a[base]-a[base-1]))+1;
printf("Case %d: ",++Kase);
printf("%d\n",ans);
}
return 0;
}