ACM零起点2017-7-28(贪心算法)

时间:2021-11-11 01:40:12

不同属性不绑定,可以使用贪心法

如果绑定,则不能贪心法解决


Radar Installation

  POJ - 1328 


Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
ACM零起点2017-7-28(贪心算法) 
Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island.Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1


思路:转换成区间选点问题,用贪心算法即可解决问题!!!即按照右端点进行对区间从小到大排序,之后详细看下面的代码中的贪心算法部分!!!


AC代码:



被坑了,特浪费一个上午时间!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Then a blank line follows to separate the cases. 被这句话坑惨了,本题目在输入时候要求多输入一个空行,如果多写一个printf("\n");则无法通过,谨记谨记!!!


 1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1005;

typedef struct
{
double x;
double y;
}point;

typedef struct
{
double x1;
double x2;
}region;

point p[maxn];
region r[maxn];

bool cmp(region r1,region r2)
{
return r1.x2<r2.x2;
}

int main()
{
int n;
double d;
int num=0;
while(scanf("%d%lf",&n,&d)!=EOF)
{
if(n==0 && d==0)break;
bool flag=1;
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&p[i].x,&p[i].y);
double t=sqrt(d*d-p[i].y*p[i].y);
r[i].x1=p[i].x-t;
r[i].x2=p[i].x+t;
if(p[i].y>d)flag=0;
}
printf("Case %d: ",++num);
if(!flag){printf("-1\n");continue;}
sort(r,r+n,cmp);
//贪心算法如下
double pos=r[0].x2;
int cnt=1;
for(int i=1;i<n;i++)
{
if(r[i].x1>pos)
{
cnt++;
pos=r[i].x2;
}
}
printf("%d\n",cnt);

}
return 0;
}