【JAVA大数训练】How Many Fibs?

时间:2022-12-27 01:02:03


How Many Fibs?


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3628    Accepted Submission(s): 1457


Problem Description


Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].


 



Input


The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.


 



Output


For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.


 



Sample Input


10 100 1234567890 9876543210 0 0


 



Sample Output


5 4


 



Source


​University of Ulm Local Contest 2000​


 



import java.math.BigInteger;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner input=new Scanner(System.in);
BigInteger [] p=new BigInteger[10010];
p[1]=BigInteger.valueOf(1);p[2]=BigInteger.valueOf(2);
for (int i = 3; i<=10000; i++) {
p[i]=p[i-1].add(p[i-2]);
}
while(input.hasNext())
{
BigInteger n=input.nextBigInteger();
BigInteger m=input.nextBigInteger();
int sum=0;
if(n.compareTo(BigInteger.ZERO)==0&&m.compareTo(BigInteger.ZERO)==0)
break;
for (int i = 1; i <=10000; i++) {
if(p[i].compareTo(n)>=0&&p[i].compareTo(m)<=0)
sum++;
}
System.out.println(sum);
}
}
}

 

总结

BigIngter a与BigIngter b比大小

如果a比b大

a.compareTo(b)>0

如果a比b小

a.compareTo(b)<0

如果a等于b

a.compareTo(b)==0