【POJ3461】Oulipo

时间:2023-03-09 14:39:29
【POJ3461】Oulipo

题面

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

题解

这是一道KMP模板题

我竟然Wa了N遍才AC(实测N=4)

题目大意:给你T组字符串,问第一个串在第二个中出现了几次

KMP太毒了,,,,老是写Wa。。。。

滑稽

这一道题用来复习KMP

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define Next nt
char a[1000100],b[1000100];
int nt[1000100];
inline void getnext()//获得字符串s的next数组
{
int l=strlen(a),t;
Next[0]=-1;//如果在0位置失配则是向下移动一位
for(int i=1;i<l;++i)//依次求解后面的next数组
{
t=Next[i-1];
while(a[t+1]!=a[i]&&t>=0)
t=Next[t];
if(a[t+1]==a[i])
Next[i]=t+1;
else
Next[i]=-1;
}
}
int KMP()
{
int l=strlen(b);
int l2=strlen(a);
int i=0,j=0;//匹配指针
int sum=0;
while(i<l)
{
if(a[j]==b[i])
{
j++;i++;
if(j==l2)//匹配完了
{
++sum;
j=nt[j-1]+1;
}
}
else//失配
{
if(j==0)//首位失配
i++;
else//跳转
j=nt[j-1]+1;
}
}
return sum;
}
int main()
{
int T;
cin>>T;
while(T--)
{
scanf("%s",a);
scanf("%s",b);
//memset(nt,0,sizeof(nt));
getnext();
cout<<KMP()<<endl;
}
return 0; }