POJ:3461-Oulipo(KMP模板题)

时间:2022-11-02 05:12:06

原题传送:http://poj.org/problem?id=3461

Oulipo

Time Limit: 1000MS Memory Limit: 65536K

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0


KMP模板


#include<stdio.h>
#include<string>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn = 1e4+100;
char s1[maxn],s2[1000100];
int next[maxn]; void cal_next()//获得next数组
{
int k;
k = next[0] = -1;
int len = strlen(s1);
for(int i=1;i<len;i++)
{
while(k>-1 && s1[i] != s1[k+1])
k = next[k];
if(s1[i] == s1[k+1])
k++;
next[i] = k;
}
} int KMP()
{
int ans = 0;
int len = strlen(s2);
int k = -1;
int len1 = strlen(s1);
for(int i=0;i<len;i++)
{
while(k>-1 && s1[k+1] != s2[i])
k = next[k];
if(s1[k+1] == s2[i])
k++;
if(k == len1-1)
{
ans++;
k = next[k];
}
}
return ans;
} int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s%s",s1,s2);
cal_next();
int ans = KMP();
printf("%d\n",ans);
}
return 0;
}