传送门:
http://acm.hdu.edu.cn/showproblem.php?pid=2199
Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25039 Accepted Submission(s): 10776
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
100
-4
Sample Output
1.6152
No solution!
No solution!
Author
Redow
Recommend
代码:
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<queue>
#include<set>
#include<map>
#include<string>
#include<memory.h>
#include<math.h>
#define eps 1e-7
using namespace std;
int y;
double f(double x)
{
return *pow(x,)+*pow(x,)+*pow(x,)+*x+-y;
}
double ff()
{
double l=,h=;
double mid;
while(h-l>=eps)//精度控制
{
mid=(l+h)/;
if(f(mid)>)
{
h=mid;
}else
{
l=mid;
}
}
return mid;
}
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>y;
if(f()*f()>)//与x轴无交点了
cout<<"No solution!"<<endl;
else
printf("%0.4lf\n",ff());
}
return ;
}