hdu 2199 Can you solve this equation?(高精度二分)

时间:2023-02-19 23:16:35
hdu 2199 Can you solve this equation?(高精度二分)

http://acm.hdu.edu.cn/howproblem.php?pid=2199

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13468    Accepted Submission(s): 6006

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define N 100010 using namespace std; int main()
{
int t, y;
double low, high, mid, k, x1, x2;
scanf("%d", &t);
while(t--)
{
scanf("%d", &y);
low = ;
high = ;
x1 = * pow(, ) + * pow(, ) + * pow(, ) + * + ;
x2 = * pow(, ) + * pow(, ) + * pow(, ) + * + ;
if(x1 <= y && y <= x2)
{
while(high - low > 1e-)/*注意1e-7*/
{
mid = (low + high) / ;
k = * pow(mid, ) + * pow(mid, ) + * pow(mid, ) + * mid + ;
if(k > y)
high = mid - 1e-;
else if(k < y)
low = mid + 1e-;
}
printf("%.4f\n", 1.0 * (low + high) / );
}
else
printf("No solution!\n"); }
return ;
}