HDOJ 2317. Nasty Hacks 模拟水题

时间:2021-07-10 08:47:02

Nasty Hacks

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3049    Accepted Submission(s): 2364
Problem Description
You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.
 
Input
The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.
Output
Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
Sample Input
3
0 100 70
100 130 30
-100 -70 40
Sample Output
advertise
does not matter
do not advertise
Source
        这个是简单模拟水题,相同的题目有HDOJ 2317、POJ 3030。
        题目大意是说,让我们决策,要不要打广告。给3个数,r,e,c,其中r代表不打广告的期望收益,e代表打广告的期望收益,c代表打广告的费用。那么把(打广告收益-广告费)和不打广告的收益比较一下就好了。
 #include <iostream>
using namespace std;
int main()
{
int n, r, e, c;
cin>>n;
while(n--)
{
cin>>r>>e>>c;
if(r<e-c) cout<<"advertise"<<endl;
else if(r>e-c) cout<<"do not advertise"<<endl;
else cout<<"does not matter"<<endl;
}
return ;
}