hdu 5591 ZYB's Game

时间:2023-03-09 02:11:49
hdu 5591 ZYB's Game
Problem Description
ZYB played a game named NumberBomb with his classmates in hiking:a host keeps a number in [,N] in mind,then
players guess a number in turns,the player who exactly guesses X loses,or the host will tell all the players that
the number now is bigger or smaller than X.After that,the range players can guess will decrease.The range is [,N] at first,each player should guess in the legal range. Now if only two players are play the game,and both of two players know the X,if two persons all use the best strategy,and the first player guesses first.You are asked to find the number of X that the second player
will win when X is in [,N].
Input
In the first line there is the number of testcases T.

For each teatcase:

the first line there is one number N.

≤T≤,≤N≤
Output
For each testcase,print the ans.
Sample Input

Sample Output

Source
 #pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<math.h>
#include<algorithm>
#include<queue>
#include<set>
#include<bitset>
#include<map>
#include<vector>
#include<stdlib.h>
#include <stack>
using namespace std;
#define PI acos(-1.0)
#define max(a,b) (a) > (b) ? (a) : (b)
#define min(a,b) (a) < (b) ? (a) : (b)
#define ll long long
#define eps 1e-10
#define MOD 1000000007
#define N 1000000
#define inf 1e12
int n;
int main()
{
int t;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
if(n%==){
printf("1\n");
}else{
printf("0\n");
} }
return ;
}