ZOJ.2105 Number Sequence【数论-快速幂矩阵】 2015/09/16

时间:2022-06-04 20:01:32
Number Sequence

Time Limit: 2 Seconds      Memory Limit: 65536 KB

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).


Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


Output

For each test case, print the value of f(n) on a single line.


Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5



Author: CHEN, Shunbao

Source: Zhejiang Provincial Programming Contest 2004


由表达式可以联想到此题可以用快速幂矩阵来做,下面就easy了

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

struct node{
    int m[2][2];
}A,per;
int a,b,p=7;

void init(){
    A.m[0][0] = A.m[1][1] = 1;
    A.m[0][1] = A.m[1][0] = 0;
    per.m[0][0] = a;
    per.m[0][1] = b;
    per.m[1][0] = 1;
    per.m[1][1] = 0;
}

node multi(node a,node b){
    node c;
    for( int i = 0 ; i < 2 ; ++i ){
        for( int j = 0 ; j < 2 ; ++j ){
            c.m[i][j] = 0;
            for( int k = 0 ; k < 2 ; ++k )
                c.m[i][j] += a.m[i][k]*b.m[k][j];
            c.m[i][j] %= p;
        }
    }
    return c;
}

void power(int k){
    node ans = A;
    while( k ){
        if( k&1 ) ans = multi(ans,per);
        per = multi(per,per);
        k/=2;
    }
    printf("%d\n",(ans.m[0][0]+ans.m[0][1])%p);
}

int main(){
    int k;
    while( ~scanf("%d%d%d",&a,&b,&k) ){
        if( !a&&!b&&!k ) break;
        a%=p,b%=p;
        if( k < 3 ){
            printf("1\n");
            continue;
        }
        init();
        power(k-2);
    }
    return 0;
}