地铁修建——CCF CSP 201703-4

时间:2022-06-23 16:24:33
试题编号: 201703-4
试题名称: 地铁修建
时间限制: 1.0s
内存限制: 256.0MB

问题描述

  A市有n个交通枢纽,其中1号和n号非常重要,为了加强运输能力,A市决定在1号到n号枢纽间修建一条地铁。
  地铁由很多段隧道组成,每段隧道连接两个交通枢纽。经过勘探,有m段隧道作为候选,两个交通枢纽之间最多只有一条候选的隧道,没有隧道两端连接着同一个交通枢纽。
  现在有n家隧道施工的公司,每段候选的隧道只能由一个公司施工,每家公司施工需要的天数一致。而每家公司最多只能修建一条候选隧道。所有公司同时开始施工。

输入格式

  输入的第一行包含两个整数n, m,用一个空格分隔,分别表示交通枢纽的数量和候选隧道的数量。
  第2行到第m+1行,每行包含三个整数a, b, c,表示枢纽a和枢纽b之间可以修建一条隧道,需要的时间为c天。
  

输出格式

  输出一个整数,修建整条地铁线路最少需要的天数。
  
样例输入

6 6
1 2 4
2 3 4
3 6 7
1 4 2
4 5 5
5 6 6

样例输出

6

样例说明
  可以修建的线路有两种。
  第一种经过的枢纽依次为1, 2, 3, 6,所需要的时间分别是4, 4, 7,则整条地铁线需要7天修完;
  第二种经过的枢纽依次为1, 4, 5, 6,所需要的时间分别是2, 5, 6,则整条地铁线需要6天修完。
  第二种方案所用的天数更少。
  
评测用例规模与约定
  对于20%的评测用例,1 ≤ n ≤ 10,1 ≤ m ≤ 20;
  对于40%的评测用例,1 ≤ n ≤ 100,1 ≤ m ≤ 1000;
  对于60%的评测用例,1 ≤ n ≤ 1000,1 ≤ m ≤ 10000,1 ≤ c ≤ 1000;
  对于80%的评测用例,1 ≤ n ≤ 10000,1 ≤ m ≤ 100000;
  对于100%的评测用例,1 ≤ n ≤ 100000,1 ≤ m ≤ 200000,1 ≤ a, b ≤ n,1 ≤ c ≤ 1000000。


1. kruskal 算法+ 查并集

//超时,只能得80分
#include<iostream>
#include<algorithm>
#include<vector>
#define MAXN 100001
#define MAXM 200001
using namespace std;
struct road { int a, b, w; };
bool com(const road r1, const road r2) { return r1.w < r2.w; }
int findroot(vector<int> set, int x) {
    while (set[x] != x) x = set[x]; 
    return x; 
}
int main() {
    int n, m, i, x, y, w, ans = 0;
    bool ist = false, iss = false;
    vector<road> roads;
    vector<int>set;
    cin >> n >> m;
    for (i = 0; i < m; ++i) {
        cin >> x >> y >> w;
        roads.push_back(road{ x - 1, y - 1, w });
    }
    for (i = 0; i < n; ++i)set.push_back(i);
    sort(roads.begin(), roads.end(), com);
    for (i = 0; i < m; ++i) {
        if (ist && iss && findroot(set, n - 1) == 0) break;
        x = findroot(set, roads[i].a);
        y = findroot(set, roads[i].b);
        if (x != y) {
            ans = max(ans, roads[i].w);
            x > y ? set[x] = y : set[y] = x;
            if (roads[i].a == n - 1 || roads[i].b == n - 1)ist = true;
            if (roads[i].a == 0 || roads[i].b == 0)iss = true;
        }
    }
    cout << ans << endl;
    return 0;
}

2. prim算法

//超时,只能得80分
#include<iostream>
#include<vector>
#include<string.h>
#include<algorithm>
#define MAXN 100001
#define MAXM 200001
#define INF 0x3f3f3f3f
using namespace std;
struct road {
    int to, w, next;
};
vector<road> roads;
vector<road> r;
vector<int> ans;
int num;
bool com(const road r1,const road  r2) {
    return r1.next < r2.next;
}
void add(int x, int y, int w) {
    while (roads[x].next != -1) x = roads[x].next;
    roads[x].next = num;
    roads[num].to = y;
    roads[num++].w = w;
}
int main() {
    int n, m, i, x, y, w, j;
    bool isar[MAXN], isa[MAXM];
    memset(isar, 0, MAXN);
    memset(isa, 0, MAXM);
    cin >> n >> m;
    num = n;
    roads.assign(2 * m + n, road{ 0, 0, -1 });
    ans.assign(n, INF);
    r.clear();
    for (i = 0; i < m; ++i) {
        cin >> x >> y >> w;
        x--, y--;
        add(x, y, w);
        add(y, x, w);
        r.push_back(road{ x, y, w });
    }
    sort(r.begin(), r.end(), com);
    ans[0] = 0;
    isar[0] = true;
    for (i = 0; i < n; ++i) {
        int v = -1;
        for (j = 0; j < m; ++j) {
            if (isa[j]) continue;
            x = r[j].to, y = r[j].w, w = r[j].next;
            if (isar[x] == true && isar[y] == true) { isa[j] = true; continue; }
            else if (isar[x] == true && isar[y] == false) { v = j; break; }
            else if (isar[x] == false && isar[y] == true) { v = j; swap(x, y); break; }
        }
        if (v == -1) break;
        isa[v] = true;
        isar[y] = true;
        ans[y] = max(ans[x], w);
        for (x = y,v = y; v != -1; v = roads[v].next) {
            y = roads[v].to;
            ans[y] = min(ans[y], max(ans[x], roads[v].w));
        }
    }
    cout << ans[n - 1] << endl;
    return 0;

}