poj3159 Candies(差分约束)

时间:2022-12-13 13:42:12

转载请注明出处: http://www.cnblogs.com/fraud/          ——by fraud

Candies
Time Limit: 1500MS   Memory Limit: 131072K

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.
 
题意:
有n个人编号为1至n,m个要求,每条要求为ui,vi,wi。代表编号ui的人分到的糖果最多只能比编号为vi的人少wi个。要求求出编号为n的人最多能比编号为1的人多几个糖果。
分析:
设x[i]代表编号为i的人所分到的糖果数目。
则可以得到如下式子x[vi]-x[ui]<=wi;
根据该式子,建图即为从ui向vi连一条权值为wi的有向边。
而后利用最短路求解。
注意:该题spfa中如果用队列会TLE,栈能AC。当然,由于该题的权值全部为正,故可采用dijkstra
 #include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <cstdlib>
using namespace std;
#define REP(A,X) for(int A=0;A<X;A++)
#define MAXE 200010
#define MAXP 30010
#define INF 0x7fffffff
#define MP(A,B) make_pair(A,B)
typedef pair<int,int> PII ;
struct node{
int v,d,next;
}edge[MAXE];
int e=;
int head[MAXP];
void init(){
e=;
REP(i,MAXP)head[i]=-;
}
void add_edge(int u,int v,int d)
{
edge[e].v=v;
edge[e].d=d;
edge[e].next=head[u];
head[u]=e;
e++;
}
int vis[MAXP],dis[MAXP];
void spfa()
{
REP(i,MAXP)vis[i]=;
REP(i,MAXP)dis[i]=i==?:INF;
//queue<int>q;
stack<int>q;
q.push();
vis[]=;
while(!q.empty()){
//int x=q.front();
int x=q.top();
q.pop();
for(int t=head[x];t!=-;t=edge[t].next)
{
int y=edge[t].v;
int d=edge[t].d;
if(dis[y]>dis[x]+d){
dis[y]=dis[x]+d;
if(!vis[y]){
q.push(y);
vis[y]=;
}
}
}
vis[x]=;
}
}
void dijkstra(int s)
{
REP(i,MAXP)vis[i]=;
REP(i,MAXP)dis[i]=i==s?:INF;
priority_queue<PII,vector<PII>,greater<PII> > q;
q.push(MP(dis[s],s));
while(!q.empty())
{
PII p=q.top();
q.pop();
int x=p.second;
if(vis[x])continue;
vis[x]=;
for(int t=head[x];t!=-;t=edge[t].next)
{
int y=edge[t].v;
int d=edge[t].d;
if(!vis[y]&&dis[y]>dis[x]+d)
{
dis[y]=dis[x]+d;
q.push(MP(dis[y],y));
}
}
} } int main()
{
int m,n;
while(scanf("%d%d",&n,&m)!=EOF){
int u,v,w;
init();
REP(i,m){
scanf("%d%d%d",&u,&v,&w);
add_edge(u,v,w);
}
//dijkstra(1);
spfa();
printf("%d\n",dis[n]);
}
return ;
}

代码君