PAT——1044. 火星数字

时间:2023-03-09 08:47:44
PAT——1044. 火星数字

火星人是以13进制计数的:

  • 地球人的0被火星人称为tret。
  • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13
 package com.hone.basical;

 import java.util.Scanner;

 /**
* 听起来很复杂,其实也就是一个进制转化的问题。
* 原题目:https://www.patest.cn/contests/pat-b-practise/1044
* 这里面有一点需要注意比如 13 直接输出 tam 而不是tam tret(因为tam本身就代表13)
* @author Xia
*/
public class basicalLevel1044MarsWords { public static void main(String[] args) {
String[] gewei = { "tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
String[] jinwei = { "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
Scanner in = new Scanner(System.in);
int n = Integer.parseInt(in.nextLine()); for (int i = 0; i < n; i++) {
String num = in.nextLine();
if (num.charAt(0) <= '9' && num.charAt(0) >= '0') {
int numN = Integer.parseInt(num);
if (numN / 13 > 0) {
if (numN%13 == 0) {
System.out.println(jinwei[numN/13-1]);
}else {
System.out.println(jinwei[numN / 13 - 1] + " " + gewei[numN % 13]);
}
} else {
System.out.println(gewei[numN]);
}
} else {
int numa = 0;
String[] numS = num.split(" ");
int k = numS.length - 1;
while (k >= 0) {
int a = 1;
for (int j = 0; j < gewei.length&&(k>=0); j++) {
if (numS[k].equals(gewei[j])) {
numa = j;
k--;
break;
}
}
for (int j = 0; j < jinwei.length&&(k>=0); j++) {
if (numS[k].equals(jinwei[j])) {
numa += (j + 1) * Math.pow(13.0, a++);
k--;
break;
}
}
System.out.println(numa);
}
}
}
} }