九度oj-1001-Java

时间:2023-03-09 16:18:06
九度oj-1001-Java

题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.    The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

2 2

1 1

1 1

-1 -1

10 9

2 3

1 2 3

4 5 6

-1 -2 -3

-4 -5 -60

样例输出:

1

5

简单翻译一下

先输入矩阵行和列的数,再列出2个矩阵的数字,然后矩阵相加,算出行数都是零和列数都是零的总和。

Java

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner; public class Main { public static void main(String[] args) {
List<Integer> mList = new ArrayList<Integer>();
Scanner cin = new Scanner(System.in);
int rows;
while ((rows = cin.nextInt()) != 0) {
int columns;
int totalTmp = 0;
int total = 0;
columns = cin.nextInt();
int[][] arrays1 = new int[rows][columns];
int[][] arrays2 = new int[rows][columns];
for (int i = 0; i < rows; i++) {
for (int j = 0; j < columns; j++) {
arrays1[i][j] = cin.nextInt();
}
}
for (int i = 0; i < rows; i++) {
for (int j = 0; j < columns; j++) {
arrays2[i][j] = cin.nextInt();
totalTmp = totalTmp | (arrays1[i][j] + arrays2[i][j]);
}
if (totalTmp == 0) {
total++;
}
totalTmp = 0;
} for (int colum = 0; colum < columns; colum++) {
for (int row = 0; row < rows; row++) {
totalTmp = totalTmp
| (arrays1[row][colum] + arrays2[row][colum]);
}
if (totalTmp == 0) {
total++;
}
totalTmp = 0;
}
mList.add(total);
}
for (int num : mList) {
System.out.println(num + "");
} }
}

我是天王盖地虎的分割线