九度OJ 1136:Number Steps(步数) (基础题)

时间:2023-03-09 17:57:51
九度OJ 1136:Number Steps(步数) (基础题)

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:691

解决:412

题目描述:

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively
and this pattern has continued.

九度OJ 1136:Number Steps(步数) (基础题)

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

输入:

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

输出:

For each point in the input, write the number written at that point or write No Number if there is none.

样例输入:
3
4 2
6 6
3 4
样例输出:
6
12
No Number
来源:
2008年北京大学软件所计算机研究生机试真题

思路:

细节题,要分清各类情况。

代码:

#include <stdio.h>

int main(void)
{
int n, i;
int x, y; while (scanf("%d", &n) != EOF)
{
for(i=0; i<n; i++)
{
scanf("%d%d", &x, &y);
if (x == y || x-y == 2)
{
if (x%2 == 0)
printf("%d\n", x+y);
else
printf("%d\n", x+y-1);
}
else
printf("No Number\n");
}
} return 0;
}
/**************************************************************
Problem: 1136
User: liangrx06
Language: C
Result: Accepted
Time:20 ms
Memory:912 kb
****************************************************************/