hdu Big Number 求一个数的位数

时间:2023-03-09 09:53:22
hdu  Big Number 求一个数的位数

Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of
the number.





Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.





Output

The output contains the number of digits in the factorial of the integers appearing in the input.





Sample Input

2

10

20





Sample Output

7

19

阶乘的位数:

log10(1)+1=1;

log10(10)+1=2;

log10(100)+1=3;

等等;

由此规律来求阶乘的位数

代码:

#include<iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
using namespace std;
int k;
double x,y;
int main()
{
int n,m,i,j; while(cin>>n)
{
while(n--)
{ x=0;
cin>>m;
for(i=1;i<=m;i++)
{
x=x+log10(i); }
k=x+1;
cout<<k<<endl;
}
}
return 0; }