2015 ACM/ICPC Asia Regional Changchun Online HDU 5444 Elven Postman【二叉排序树的建树和遍历查找】

时间:2022-10-13 05:07:38

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 591    Accepted Submission(s): 329

Problem Description
Elves
are very peculiar creatures. As we all know, they can live for a very
long time and their magical prowess are not something to be taken
lightly. Also, they live on trees. However, there is something about
them you may not know. Although delivering stuffs through magical
teleportation is extremely convenient (much like emails). They still
sometimes prefer other more “traditional” methods.

So, as a
elven postman, it is crucial to understand how to deliver the mail to
the correct room of the tree. The elven tree always branches into no
more than two paths upon intersection, either in the east direction or
the west. It coincidentally looks awfully like a binary tree we human
computer scientist know. Not only that, when numbering the rooms, they
always number the room number from the east-most position to the west.
For rooms in the east are usually more preferable and more expensive due
to they having the privilege to see the sunrise, which matters a lot in
elven culture.

Anyways, the elves usually wrote down all the
rooms in a sequence at the root of the tree so that the postman may know
how to deliver the mail. The sequence is written as follows, it will go
straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then
go to the next unvisited east-most room, writing down every unvisited
room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

2015 ACM/ICPC Asia Regional Changchun Online  HDU 5444 Elven Postman【二叉排序树的建树和遍历查找】

 
Input
First you are given an integer T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.

 
Output
For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

 
Sample Input
2 //代表有2组测试数据
 
4 //有4个数据需要插入到二叉树上
2 1 4 3
3  //代表3次询问
1 2 3
 
6
6 5 4 3 2 1
1
1
 
Sample Output
E
  //输出为空 因为2就是根节点 并没有移动
WE
EEEEE
Source
 
直接复制题目后出现了问题:原题请看http://acm.hdu.edu.cn/showproblem.php?pid=5444
 
分析:为了复习一下数据结构,把此题的代码贴了出来,也便于以后复习用。这是一道简单的数据结构的问题,可以看成是建立一颗倒着的二叉排序树。
然后我们再去查找树上的元素,W和E代表左右移动方向最后到达目标数字。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <ctype.h>
#include <queue>
#include <algorithm> using namespace std; typedef struct node
{
int data;
struct node *ll;
struct node *rr;
}Binode, *Bitree; void creat_sort_Bitree(Bitree &root, int key)
{
if(root==NULL){
root=new Binode;//一种类型
root->data=key;
root->ll=NULL;
root->rr=NULL;
return ;//插入到二叉排序树上成功 返回
}
else{
if(key < root->data){
creat_sort_Bitree(root->ll, key);
}else{
creat_sort_Bitree(root->rr, key);
}
}
} queue<char>q;
void get_aim(Bitree &root, int key)
{
if(root->data == key){
return;
}else{
if(root->data > key){
q.push('E');
get_aim(root->ll, key);
}
else{
q.push('W');
get_aim(root->rr, key);
}
}
} int main()
{
int tg; scanf("%d", &tg);
int n, i, j, dd, m;
Bitree root; while(tg--){
root=NULL; //初始化root必须为空! 这个root的值在确定了根节点后是不会改变的
scanf("%d", &n);
while(n--){
scanf("%d", &dd);
creat_sort_Bitree(root, dd);
} scanf("%d", &m);
while(m--){
scanf("%d", &dd); //在二叉排序树中将找出来
while(!q.empty()) q.pop();//全局变量队列记得清空后在使用
get_aim(root, dd);
while(!q.empty()){
printf("%c", q.front()); q.pop();
}printf("\n");
}
}
return 0;
}