POJ 3414 Pots

时间:2020-12-01 09:40:06
Pots

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

注:本人英语很渣,题目大意大多来自百度~=0=

 

题目大意:

给出了两个瓶子的容量a,b, 以及一个目标水量n

对A、B可以有如下操作:

FILL(i)        把i倒满

DROP(i)      把i倒空

POUR(i,j)     把i倒入j

问经过哪几个操作后能使得任意一个瓶子的水量为C。

若不可能得到则输出impossible

输入就是A(a) B(b) C(n)

输出第一行是一共需要几次操作

下面是每行是一次操作

解题思路 :

BFS

每次操作有8种可能(额,我是按照自己题解写的序号 将就着看吧=0=)

a倒入b时:

1.倒满, a剩余

7.倒空,a为0

b倒入a时:

2.倒满, b剩余

8.倒空,b为0

当a不满时

3.FILL(a)

当b不满时

4.FILL(b)

当a != 0时

5.倒空a

当b != 0时

6.倒空b

由于输出需要步骤,所以我用结构体保存了前一个状态的oa, ob, oc(原因是这三个都需要才能找到上一个操作)

代码如下:

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include <queue>
#define N 110
#define INF 0xfffffff
using namespace std;
int a, b, n;
bool f[N][N][]; //f用来判断此状态是不是已经使用过
struct node
{
int a, b, step, oa, ob, c, oc;//a, b 状态的下标, c 状态操作 o+..是指前一个状态
}s, e, ans[N][N][]; //ans用来保存每一个状态的值
void Putc(int c)
{
if(c == || c == ) printf("POUR(1,2)\n");
if(c == ) printf("DROP(1)\n");
if(c == || c == ) printf("POUR(2,1)\n");
if(c == ) printf("DROP(2)\n");
if(c == ) printf("FILL(1)\n");
if(c == ) printf("FILL(2)\n");
}
void inPut(node s)
{
int d[N], dd = ;
printf("%d\n", s.step);
d[dd++] = s.c;
while(s.a || s.b) {
s = ans[s.oa][s.ob][s.oc];
d[dd++] = s.c; //将之前每一个操作储存起来 最后输出 因为如果直接输出顺序回事反的
}
for(int i = dd - ; i >= ; i--)
Putc(d[i]);
}
void Init() //初始化
{
memset(f, false, sizeof(f));
memset(ans, , sizeof(ans));
}
void BFS()
{
queue<node>q;
s = {, , };
q.push(s);
f[s.a][s.b][s.c] = ;
while(!q.empty()) {
s = q.front();
q.pop();
if(s.a == n || s.b == n) {
inPut(s);
return;
}
if(s.a != ) {
//a->b
if(s.a + s.b > b){//b被倒满a有剩余
e = {s.a - (b - s.b), b, s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
else {//a倒b 无剩余
e = {, s.a + s.b, s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
//倒空a
e = {, s.b, s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
if(s.b != ) {
//b->a
if(s.a + s.b > a){//a被倒满b有剩余
e = {a, s.b - (a - s.a), s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
else {//b倒a 无剩余
e = {s.a + s.b, , s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
//~倒空b
e = {s.a, , s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
//把a加满
if(s.a != a) {
e = {a, s.b, s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
//把b加满
if(s.b != b){
e = {s.a, b, s.step + , s.a, s.b, , s.c};
if(!f[e.a][e.b][e.c])
q.push(e), f[e.a][e.b][e.c] = , ans[e.a][e.b][e.c] = e;
}
}
printf("impossible\n");
}
int main()
{
while (~scanf("%d %d %d", &a, &b, &n)) {
Init();
BFS();
}
}