1055. The World's Richest (25)

时间:2023-03-10 07:27:58
1055. The World's Richest (25)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths
of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines
follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines
of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must
be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In
case no one is found, output "None".

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

思路:因为只有200个年龄,输入的行数最长有100000,平均每个年龄有500.加上M最大只有100,所以有些数据需要剔除。
注释部分是超时的代码(test 2不能通过),主要原因是每输入一个M min max,就要把一些vector排序,有重复。
/*
#include <iostream>
#include"stdio.h"
#include"stdlib.h"
#include"string.h"
#include"algorithm"
#include"vector"
using namespace std; struct person{
char name[9];
int age;
long worth;
}; bool comparePersonByWorth(struct person p1, struct person p2){
if(p1.worth>p2.worth){
return true;
}
return false;
} bool compare(struct person p1,struct person p2){
if(p1.worth>p2.worth)
return true;
if(p1.worth==p2.worth){
if(p1.age<p2.age)
return true;
if(p1.age==p2.age){
if(strcmp(p1.name,p2.name)<0){
return true;
}
}
}
return false;
}
int main()
{
vector<struct person> v[201];
long N;
int K; int M,minn,maxn; scanf("%ld%d",&N,&K); struct person p; for(long i=0;i<N;i++){
scanf("%s%d%ld",p.name,&p.age,&p.worth);
v[p.age].push_back(p);
} for(long i=1;i<=200;i++){
if(v[i].size()>100)
sort(v[i].begin(),v[i].begin(),comparePersonByWorth);
} int v_size,length,s;
for(int i=1;i<=K;i++){ scanf("%d%d%d",&M,&minn,&maxn); vector<struct person> v2 = v[minn]; for(int j=minn+1;j<=maxn;j++){
v_size = v[j].size();
length = (100>v_size)?v_size:100; v2.insert(v2.end(),v[j].begin(),v[j].begin()+length);
} printf("Case #%d:\n",i);
if(!v2.empty()){
sort(v2.begin(),v2.end(),compare);
v_size = v2.size();
s = (M>v_size)?v_size:M;
for(int k=0;k<s;k++){
printf("%s %d %ld\n",v2[k].name,v2[k].age,v2[k].worth);
}
}
else
{
printf("None\n");
}
}
return 0;
}
*/
#include <iostream>
#include"stdio.h"
#include"stdlib.h"
#include"string.h"
#include"algorithm"
#include"vector"
using namespace std; struct person{
char name[9];
int age;
long worth;
}; bool comparePersonByWorth(struct person p1, struct person p2){
if(p1.worth>p2.worth){
return true;
}
return false;
} bool compare(struct person p1,struct person p2){
if(p1.worth>p2.worth)
return true;
if(p1.worth==p2.worth){
if(p1.age<p2.age)
return true;
if(p1.age==p2.age){
if(strcmp(p1.name,p2.name)<0){
return true;
}
}
}
return false;
}
int main()
{
vector<struct person> v[201];
long N;
int K; int M,minn,maxn; scanf("%ld%d",&N,&K); struct person p; for(long i=0;i<N;i++){
scanf("%s%d%ld",p.name,&p.age,&p.worth);
v[p.age].push_back(p);
} vector<struct person> v2; int v_size,length,s;
for(long i=1;i<=200;i++){
/*如果相同年龄的富豪超过100个,则按照财富值筛选出前100*/
if(v[i].size()>100){
sort(v[i].begin(),v[i].end(),comparePersonByWorth); }
v_size = v[i].size();
length = (100>v_size)?v_size:100;
v2.insert(v2.end(),v[i].begin(),v[i].begin()+length);
}
sort(v2.begin(),v2.end(),compare); for(int i=1;i<=K;i++){
scanf("%d%d%d",&M,&minn,&maxn);
bool flag = false;
printf("Case #%d:\n",i);
int cnt = 0;//记录已经输出的富豪数目
for(int k=0;cnt<M&&k<v2.size();k++){
if(v2[k].age>=minn&&v2[k].age<=maxn){
printf("%s %d %ld\n",v2[k].name,v2[k].age,v2[k].worth);
flag = true;
cnt++;
}
} if(flag==false)
{
printf("None\n");
}
}
return 0;
}