[ACM] POJ 1035 Spell checker (单词查找,删除替换添加不论什么一个字母)

时间:2021-10-11 16:56:39
Spell checker
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18693   Accepted: 6844

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.


If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:


?deleting of one letter from the word;

?

replacing of one letter in the word with an arbitrary letter;

?

inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000
words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.


All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct".
If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary
(in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source



解题思路:

输入词典中的单词,再输入须要查找的单词,查找到有四种方法:

1.  该单词存在词典中

2.该单词通过替换不论什么一个字母后存在于词典中(假设有多个,按词典序输出)

3.该单词通过删除不论什么一个字母后存在于词典中

4.该单词通过添加一个字母后存在于词典中

做本题遇到的问题:

char dic[ ] [ ] 存词典,  char wor[] [] 存待查找的单词。

在推断单词能否通过删除一个字母后存在于词典中时。由于函数传的是指针,而函数中又把字母的顺序移动了,这就造成把原单词给改变了,这个错误太致命了。。。事实上推断上面说的后两种情况能够通过指针移动,推断不匹配的个数,单词的指针为i, 词典某个单词的指针为j ,  当它们的字母同样时,i++,j++,不同一时候, 就让单词长度长的那个指针+1,mistake+1还有一个不动,mistake的个数不能大于1。(由于推断的两个单词长度之差的绝对值不会大于1).

还有有个地方严重超时,以下代码:

bool replace(char *a,char *b)
{
string s1=a,s2=b;
int len1=s1.length();
int mistake=0;
for(int i=0;i<len1;i++)
if(s1[i]!=s2[i])
mistake++;
if(mistake==1)
return true;
return false;
}

直接操作就能够:

bool replace(char *a,char *b)//推断单词能否替换掉一个字母而成为词典中的单词
{
int len1=strlen(a);
int mistake=0;
for(int i=0;i<len1;i++)
if(a[i]!=b[i])
{
mistake++;
if(mistake>1)
return false;
}
return true;
}

代码:

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn=10010;
char dic[maxn][20];
char wor[60][20];
int dn,wn;//字典词的个数,须要查询的个数 bool correct(char *s1)//推断该单词是否存在于词典中
{
for(int i=1;i<=dn;i++)
if(strcmp(s1,dic[i])==0)
return true;
return false;
}
bool replace(char *a,char *b)//推断单词能否替换掉一个字母而成为词典中的单词
{
int len1=strlen(a);
int mistake=0;
for(int i=0;i<len1;i++)
if(a[i]!=b[i])
{
mistake++;
if(mistake>1)
return false;
}
return true;
}
bool del(char *a,char *b)//推断单词能否通过删除一个字母而成为词典中的单词
{
int len1=strlen(a);
int i=0,j=0;
int mistake=0;
while(i<len1)
{
if(a[i]!=b[j])
{
i++;
mistake++;
if(mistake>1)
return false;
}
else
{
i++;
j++;
}
}
return true;
} int main()
{
dn=1;
wn=1;
while(cin>>dic[dn]&&dic[dn][0]!='#') dn++;
while(cin>>wor[wn]&&wor[wn][0]!='#') wn++;
dn--;wn--;
for(int i=1;i<=wn;i++)
{
if(correct(wor[i]))//首先去词典中查找有没有当前词
{
cout<<wor[i]<<" is correct"<<endl;
continue;
}
cout<<wor[i]<<": ";
for(int j=1;j<=dn;j++)
{
int len1=strlen(wor[i]);
int len2=strlen(dic[j]);
if(len1==len2)//长度相等
{
if(replace(wor[i],dic[j]))
cout<<dic[j]<<" ";
}
else if(len1-len2==1)//看单词是否删除一个字母后跟词典中匹配
{
if(del(wor[i],dic[j]))
cout<<dic[j]<<" ";
}
else if(len1-len2==-1)//添加一个字母后跟词典中匹配
{
if(del(dic[j],wor[i]))
cout<<dic[j]<<" ";
}
}
cout<<endl;
}
return 0;
}