POJ 1995:Raising Modulo Numbers 快速幂

时间:2021-12-09 12:08:19
Raising Modulo Numbers
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5532   Accepted: 3210

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 



Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 



You should write a program that calculates the result and is able to find out who won the game. 


Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

题意就是求(A1B1+A2B2+ ... +AHBH)mod M.

原来求一个数A的B次幂都是一级一级循环,时间复杂度是O(n),且最后取余M的话很容易溢出。

快速幂:比方说求2的9次幂,它的思想是求2的4次幂*2的4次幂*2,这样2的4次幂只需求一次。2的4次幂怎么求,还是和原来一样,是2的2次幂*2的2次幂,2的2次幂等于2*2;

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std; long long getresult(long long m,long long n,long long k)
{
long long b = 1;
while (n > 0)
{
if (n & 1)
b = (b*m) % k;
n = n >> 1;
m = (m*m) % k;
}
return b;
}
int main()
{
//freopen("i.txt","r",stdin);
//freopen("o.txt","w",stdout); long long Test,i,n,k,temp1,temp2,result;
cin>>Test; while(Test--)
{
result = 0; cin >> k >> n;
for (i = 1; i <= n; i++)
{
cin >> temp1 >> temp2;
result += getresult(temp1, temp2, k);
result = result%k;
}
cout << (result%k) << endl;
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。