nyoj VF

时间:2021-03-07 15:06:32

VF

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
 
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
 
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10

#include <iostream>
#include <cstring>
using namespace std;

int dp[10][82];//前i位的和为j
int main()
{
memset(dp,0,sizeof(dp));
for(int i=1;i<10;i++)//当n==1的时候,有1 10 100 1000 -----1000000000这些情况
dp[1][i]=1;

for(int i=1;i<10;i++)//前i位
for(int j=1;j<=i*9;j++)//和为j的情况,最大的是前i位每位的数字都是9
for(int k=0;k<=9&&k<=j;k++)//当第i位为k时
dp[i][j]+=dp[i-1][j-k];//前i位和为j的情况=前i位和为j的情况+前i-1位和为j-k的情况

int n;
while(cin>>n)
{
int sum=0;
if(n==1)
cout<<10<<endl;
else
{
for(int i=1;i<10;i++)
sum+=dp[i][n];
cout<<sum<<endl;
}
}
return 0;
}