POJ 1469 && ZOJ 1140 --COURSES【二分图 && 最大匹配】

时间:2021-10-02 06:15:01

COURSES
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19581   Accepted: 7709

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

题意:

N个学生和P门课程,每个学生学习0, 1 或者多门课程,判断是否能从这些学生中选出P名学生,组成一个委员会,满足以下条件:

(1)委员会中的每名学生代表一门不同的课程,只有学生学习了这门课程,他才可以代表这门课程

(2)每个课程在委员会中必须有一名代表。


解析:

读完题就可以确定这是个基本的二分图求最大匹配问题。水题一个,就不多说了。


#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 330
using namespace std;

int map[maxn][maxn];
int used[maxn];
int link[maxn];
int N, P;

void getmap(){
    for(int i = 1; i <= P; ++i){
        int m;
        scanf("%d", &m);
        for(int j = 1; j <= m; ++j){
            int b;
            scanf("%d", &b);
            map[i][b] = 1;
        }
    }
}

bool dfs(int x){
    for(int i = 1; i <= N; ++i){
        if(map[x][i] && !used[i]){
            used[i] = 1;
            if(link[i] == -1 || dfs(link[i])){
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int hungary(){
    int ans = 0;
    memset(link, -1, sizeof(link));
    for(int i = 1; i <= P; ++i){
        memset(used, 0, sizeof(used));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main (){
    int T;
    scanf("%d", &T);
    while(T--){
        scanf("%d%d", &P, &N);
        memset(map, 0, sizeof(map));
        getmap();
        int sum = hungary();
        if(sum == P)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}