Java - PAT - 1001. A+B Format (20)

时间:2021-10-19 18:44:52

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

题目的大概意思就是

 程序运行一次 输入一组测试数据,每组测试数据有a,b两个,中间用空格隔开

 在一行中输出a+b的和,数字的格式是标准格式


题目简单,只要用个格式化输出即可


import java.util.Scanner;
public class Main {
    public static void main(String[] args){
        Scanner sc=new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        System.out.printf("%,d", a+b);
    }
}