HDU 5073 Galaxy (2014 Anshan D简单数学)

时间:2022-02-01 08:25:24

HDU 5073 Galaxy (2014 Anshan D简单数学)

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=5073

Description

Good news for us: to release the financial pressure, the government started selling galaxies and we can buy them from now on! The first one who bought a galaxy was Tianming Yun and he gave it to Xin Cheng as a present.HDU 5073 Galaxy (2014 Anshan D简单数学)To be fashionable, DRD also bought himself a galaxy. He named it Rho Galaxy. There are n stars in Rho Galaxy, and they have the same weight, namely one unit weight, and a negligible volume. They initially lie in a line rotating around their center of mass.

Everything runs well except one thing. DRD thinks that the galaxy rotates too slow. As we know, to increase the angular speed with the same angular momentum, we have to decrease the moment of inertia.

The moment of inertia I of a set of n stars can be calculated with the formulaHDU 5073 Galaxy (2014 Anshan D简单数学)

where wi is the weight of star i, di is the distance form star i to the mass of center.

As DRD’s friend, ATM, who bought M78 Galaxy, wants to help him. ATM creates some black holes and white holes so that he can transport stars in a negligible time. After transportation, the n stars will also rotate around their new center of mass. Due to financial pressure, ATM can only transport at most k stars. Since volumes of the stars are negligible, two or more stars can be transported to the same position.

Now, you are supposed to calculate the minimum moment of inertia after transportation.

Input

The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers, n(1 ≤ n ≤ 50000) and k(0 ≤ k ≤ n), as mentioned above. The next line contains n integers representing the positions of the stars. The absolute values of positions will be no more than 50000.

Output

For each test case, output one real number in one line representing the minimum moment of inertia. Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.

Sample Input

2

3 2

-1 0 1

4 2

-2 -1 1 2

Sample Output

0

0.5

题意:

给你n个在x轴点,其中k个可以任意变换坐标点,问此时每个点距离质心的距离平方和最小是多少?

题解:

首先将所有的点排序。然后每次o(n)扫描一遍。首先我们知道质心是每个坐标的和的平均值。那么从头到尾扫描每次删除起始点,添加最后点的下一个点。我们只需将这个公式拆开即可化简。注意n==k的时候输出0

代码:

#include <bits/stdc++.h>

const int N = 100005 ;

double pos[N] ;

int main()
{
int t ;
scanf("%d",&t) ;
while(t--){
int n , k ;
scanf("%d %d",&n,&k) ;
for(int i = 1 ; i <= n ; i ++){
scanf("%lf",pos+i) ;
}
if(n == k){
printf("0\n") ;
continue ;
}
std::sort(pos+1,pos+1+n) ;
double sum = 0 ;
double psum = 0 ;
for(int i = 1 ; i <= n-k ; i ++){
sum += pos[i] ;
psum += pos[i]*pos[i] ;
}
double avg = sum/(n-k) ;
double ans = psum + (n-k)*avg*avg - 2*avg*sum ;
for(int i = 1 ; i <= k ; i ++){
sum -= pos[i] ;
sum += pos[n-k+i] ;
psum -= pos[i]*pos[i] ;
psum += pos[n-k+i]*pos[n-k+i] ;
avg = sum/(n-k) ;
double temp = psum + (n-k)*avg*avg - 2*avg*sum ;
ans = std::min(ans,temp) ;
}
printf("%.10lf\n",ans) ;
}
return 0 ;
}
posted @
2016-10-02 23:42 
Thecoollight 
阅读(...) 
评论(...) 
编辑 
收藏