算法训练 5-1最小公倍数

时间:2022-07-31 11:04:23
问题描述
  编写一函数lcm,求两个正整数的最小公倍数。
样例输入
一个满足题目要求的输入范例。
例:

3 5
样例输出
与上面的样例输入对应的输出。
例:
算法训练 5-1最小公倍数
数据规模和约定
  输入数据中每一个数的范围。
  例:两个数都小于65536。
 
 
 
 
 

#include <iostream>
using namespace std;

void GBS(long long &x,long long &y){
long long ans = 1;
for(int i = x;i >= 2 ;i --){
if(x%i == 0 && y%i == 0){
ans = ans * i;
x = x/i;
y = y/i;

}
}

ans = ans*x*y;
cout << ans;
}

int main() {
long long x,y, ans;
cin >> x >> y;
if(x > 2 && y > 2){
if(x > y){
GBS(y,x);
}
else{
GBS(x,y);
}
}
else if(x == y == 2){
ans = 2;
cout << ans;
}
else {
ans = x * y;
cout << ans;
}


return 0;
}