数据结构实验之二叉树的建立与遍历

时间:2022-06-15 10:30:56

数据结构实验之二叉树的建立与遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

 输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfacgefdba35

提示

 

来源

 ma6174

示例程序

#include<iostream>
#include<cstdio>
using namespace std;
typedef struct node
{
char data;
struct node *ltree,*rtree;
} *lit;
int i=0,j=0;
void creat_tree(lit &p)
{
char c;
cin>>c;
if(c==',')
{
p=NULL;
}
else
{
p=new node;
p->data=c;
creat_tree(p->ltree);//递归调用建树
creat_tree(p->rtree);
}
}
void zhongxu(lit &p)//中序遍历
{
if(p)
{
if(!p->ltree&&!p->rtree)//求叶子节点
++i;
zhongxu(p->ltree);
cout<<p->data;
zhongxu(p->rtree);
}

}
void houxu(lit &p)//后序遍历
{
if(p)
{
houxu(p->ltree);
houxu(p->rtree);
cout<<p->data;
}

}
int Depth(lit &p)// 用递归获取最大深度
{
if (p == NULL)
return 0;
else
return 1 + Depth(p->ltree)>Depth(p->rtree)?
(Depth(p->ltree)+1):(Depth(p->rtree)+1);

}
int main()
{
lit p;
creat_tree(p);
zhongxu(p);
cout<<endl;
houxu(p);
cout<<endl;
cout<<i<<endl;
j=Depth(p);
cout<<j<<endl;

}