PAT乙级练习题B1009. 说反话

时间:2023-02-27 16:09:32

题目描述

给定一句英语,要求你编写程序,将句中所有单词的顺序颠倒输出。

输入格式:测试输入包含一个测试用例,在一行内给出总长度不超过80的字符串。字符串由若干单词和若干空格组成,其中单词是由英文字母(大小写有区分)组成的字符串,单词之间用1个空格分开,输入保证句子末尾没有多余的空格。

输出格式:每个测试用例的输出占一行,输出倒序后的句子。

输入样例:
Hello World Here I Come
输出样例:
Come I Here World Hello

代码

#include<iostream>
#include<string>
#include<vector>
using namespace std;

void Reverse(vector<string> &line)
{
for (int i = 0, j = (line.size() - 1); i < j; ++i, --j)
{
string temp;
temp = line[i];
line[i] = line[j];
line[j] = temp;
}
}

int main()
{
string word;
vector<string> line;
while (cin >> word)
{
line.push_back(word);
}
Reverse(line);
for (auto it = line.begin(); it != line.end(); ++it)
{
cout << *it;
if (it != (line.end() - 1))
cout << " ";
else
cout << endl;
}
return 0;
}