hdu1002 A + B Problem II(高精度加法) 2016-05-19 12:00 106人阅读 评论(0) 收藏

时间:2023-02-13 12:16:56

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 308484    Accepted Submission(s): 59635

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3 Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
-----------------------------------------------------------------------------------------------------------------------------------------------
高精度加法计算,数值位数太大,用字符处理,按位计算,为了方便末尾对齐,采取先取反再相加在取反;
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
void un(char *a,int k) //取反
{
for(int i=0;i<k/2;i++)
swap(a[i],a[k-1-i]);
}
int main()
{
char a[1005],b[1005],c[1005],A[1005],B[1005];
int k1,k2,k;
int o;
while(~scanf(" %d",&o))
{
int t=0;
int q=o;
while(o--)
{
memset(c,'0',sizeof(c));
scanf(" %s %s",A,B);
strcpy(a,A);
strcpy(b,B);
k1=strlen(a);
k2=strlen(b);
un(a,k1);
un(b,k2);
if(k1>k2)//补零以对齐;
{
k=k1;
for(int i=k2;i<k;i++)
b[i]='0';
}
else
{
k=k2;
for(int i=k1;i<k;i++)
a[i]='0'; }
for(int i=0;i<k;i++)//相加和进位
{
c[i]=c[i]+(a[i]-'0')+(b[i]-'0');
if(c[i]>'9')
{
c[i]-=10;
c[i+1]+=1;
}
}
printf("Case %d:\n%s + %s = ",++t,A,B);
if(c[k]>'0') //最高位进位单独考虑
printf("%c",c[k]);
for(int i=k-1;i>=0;i--)
{
printf("%c",c[i]);
}
printf("\n");
if(t!=q)
printf("\n");
} }
return 0;
}

hdu1002 A + B Problem II(高精度加法) 2016-05-19 12:00 106人阅读 评论(0) 收藏的更多相关文章

  1. A simple problem 分类: 哈希 HDU 2015-08-06 08&colon;06 1人阅读 评论&lpar;0&rpar; 收藏

    A simple problem Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) To ...

  2. short-path problem &lpar;Floyd&rpar; 分类: ACM TYPE 2014-09-01 23&colon;58 100人阅读 评论&lpar;0&rpar; 收藏

    #include <cstdio> #include <iostream> #include <cstring> using namespace std; cons ...

  3. short-path problem &lpar;Dijkstra&rpar; 分类: ACM TYPE 2014-09-01 23&colon;51 111人阅读 评论&lpar;0&rpar; 收藏

    #include <cstdio> #include <iostream> #include <cstring> using namespace std; cons ...

  4. leetcode N-Queens&sol;N-Queens II&comma; backtracking&comma; hdu 2553 count N-Queens&comma; dfs 分类: leetcode hdoj 2015-07-09 02&colon;07 102人阅读 评论&lpar;0&rpar; 收藏

    for the backtracking part, thanks to the video of stanford cs106b lecture 10 by Julie Zelenski for t ...

  5. 多校赛3- Solve this interesting problem 分类: 比赛 2015-07-29 21&colon;01 8人阅读 评论&lpar;0&rpar; 收藏

    H - Solve this interesting problem Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I ...

  6. Train Problem I 分类: HDU 2015-06-26 11&colon;27 10人阅读 评论&lpar;0&rpar; 收藏

    Train Problem I Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) ...

  7. The 3n &plus; 1 problem 分类: POJ 2015-06-12 17&colon;50 11人阅读 评论&lpar;0&rpar; 收藏

    The 3n + 1 problem Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 53927   Accepted: 17 ...

  8. HDu 1001 Sum Problem 分类: ACM 2015-06-19 23&colon;38 12人阅读 评论&lpar;0&rpar; 收藏

    Sum Problem Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total ...

  9. HDU 2101 A &plus; B Problem Too 分类: ACM 2015-06-16 23&colon;57 18人阅读 评论&lpar;0&rpar; 收藏

    A + B Problem Too Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others ...

随机推荐

  1. Java继承与组合

    Java继承与组合 继承 java 中使用extends关键字表示继承关系,当创建一个类时,如果没有明确指出要继承的类,则是隐式地从根类Object进行继承. 子类继承父类的成员变量 子类能够继承父类 ...

  2. Uncaught SyntaxError&colon; Unexpected token ILLEGAL

    原因,相关的JS函数中,存在一个中文逗号,修改即可正常执行

  3. 你应该知道CSS选择器技巧

    什么是:before和:after? 该如何使用他们? :before是css中的一种伪元素,可用于在某个元素之前插入某些内容. :after是css中的一种伪元素,可用于在某个元素之后插入某些内容. ...

  4. OMCS开发手册(02) -- 多媒体连接器

    OMCS开发手册(01) -- 多媒体设备管理器 一文,我们从Owner的角度详细描述了多媒体设备管理器的使用,本文我们将站在Guest的角度,描述OMCS中另一类组件/控件:多媒体连接器.多媒体连接 ...

  5. Y2 MyBatis&lpar;二&rpar;

    春节后的第一次课 1.整合日志(log4j和logback) (1)log4j和logback都是一个日志记录框架 (2)appender记住两个 stdout控制台显示日志,file记录文件中 (3 ...

  6. 运行 Spring Boot 应用的 3 种方式

    今天介绍 3 种运行 Spring Boot 应用的方式,看大家用过几种? 你所需具备的基础 什么是 Spring Boot? Spring Boot 核心配置文件详解 Spring Boot 开启的 ...

  7. 运行gulp项目报错:AssertionError&colon; Task function must be specified。

    一.问题描述: gulp项目在本地windows 10机器上跑没有任何问题,但是放在centos 7虚拟机上跑报错:AssertionError: Task function must be spec ...

  8. jmeter(三)SOAP&sol;XML-RPC Request

    项目背景:公司的微信端H5界面新开发了会员注册功能,需要对其进行压力测试 项目目标:需要承受每分钟最少6000的压力 一.建立一个测试计划(test plan) 之前有说过,jmeter打开后会自动生 ...

  9. Lua常用封装方法

    Lua 获取随机值 --获取随机值,指定上限和下限 function getRandom(min,max) -- 接收一个整数n作为随即序列的种子 math.randomseed(os.time()) ...

  10. bzoj4814&colon; &lbrack;Cqoi2017&rsqb;小Q的草稿

    Description 小Q是个程序员.众所周知,程序员在写程序的时候经常需要草稿纸.小Q现在需要一张草稿纸用来画图,但是桌上 只有一张草稿纸,而且是一张被用过很多次的草稿纸.草稿纸可以看作一个二维平 ...