[poj] 1979 Red and Black [dfs]

时间:2022-09-12 23:46:57

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output

45
59
6
13

dfs入门题

#include<cstdio>
#include<string>
#define MAX_N 22
using namespace std;
char _map[MAX_N][MAX_N];
int h,w,cnt;
int s_x,s_y;
int ox[]={0,0,1,-1};
int oy[]={1,-1,0,0};

int dfs(int X,int Y){
    cnt++;
    _map[X][Y]='N';//随便用个什么 标记一下走过的
    for(int i=0;i<4;i++){
        int x=X+ox[i];
        int y=Y+oy[i];
        if(0<=x&&x<h&&0<=y&&y<w&&_map[x][y]=='.')
            dfs(x,y);
    }
}

int main(){
    while(~scanf("%d%d",&w,&h)&&(w||h)){
        for(int i=0;i<h;i++)
            scanf("%s",_map[i]);
        for(int j=0;j<h;j++)
            for(int k=0;k<w;k++)
                if(_map[j][k]=='@')
                    s_x=j,s_y=k;
        cnt=0;dfs(s_x,s_y);
        printf("%d\n",cnt);
    }
    return 0;
}