POJ 1146 ID Codes 求下一个字典序

时间:2023-02-02 20:27:12
点击打开链接
ID Codes
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5624   Accepted: 3360

Description

It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) 

An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set. 

For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are: 
      abaabc

abaacb

ababac


These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. 

Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters. 

Input

Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

Output

Output will consist of one line for each code read containing the successor code or the words 'No Successor'.

Sample Input

abaacb
cbbaa
#

Sample Output

ababac
No Successor

Source

New Zealand 1991 Division I,UVA 146

给你一个字典序,让你求下一个字典序,如果没有则输出No Successor 可以用排列组合里面的方法求下一个字典序点击打开链接 也可以用STL里面的next_permutation函数一步求出。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int len,n;
bool nextpermutation(char *s)//s为序列的数组
{
int i=len-1,j;//len为长度
while(i>0&&s[i-1]>=s[i])i--;//从右往左找第一个比右边小的序号j
if(!i)return false;//如果找不到,则是最后一个排列
int mp=i;
for(j=i+1; j<len; j++)//在pj的右边的字符中,找出所有比pj大的字符中最小的字符pk
{
if(s[i-1]>=s[j])continue;
if(s[j]<s[mp])mp=j;
}
swap(s[mp],s[i-1]);//交换pj,pk
sort(s+i,s+len);//再将pj+1......pk-1pkpk+1pn倒转得到排列p''=p1p2.....pj-1pjpn.....pk+1pkpk-1.....pj+1
return len;
}
int main()
{
char s[107];
while(scanf("%s",s)!=EOF,s[0]!='#')
{

len=strlen(s);
if(nextpermutation(s))
printf("%s\n",s);
else printf("No Successor\n");
}
return 0;
}

#include<stdio.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
string str;
while(cin>>str,str[0]!='#')
{
bool flag=true;
if(next_permutation(str.begin(),str.end()))
{
flag=false;
cout<<str<<endl;
}
if(flag)printf("No Successor\n");
}
}