Encoding

时间:2024-01-21 12:53:39
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
Output
For each test case, output the encoded string in a line.
Sample Input
2
ABC
ABBCCC
Sample Output
ABC
A2B3C
Author
ZHANG Zheng
#include<cstdio>
#include<cstring>
int main()
{
int N;
int a[];
int v;
int temp=;
scanf("%d",&N);
getchar();
while(N--)
{
memset(a,,sizeof(a));
v=getchar();
temp=v;
while(temp!='\n')
{ if(v!=temp)
{
if(a[temp]>) printf("%d%c",a[temp],temp);
if(a[temp]==) printf("%c",temp);
a[temp]=;
a[v]++;
}
else a[v]++;
temp=v;
if(v!='\n') v=getchar();
}
printf("\n");
}
}
/*题意没看清,wa了几次,题目说了是子序列,那么对于例子 AABBBCCCAABB 应输出2A3B3C2A2B*/