zoj 1610 Count the Colors 【区间覆盖 求染色段】

时间:2023-01-26 07:47:41

Count the Colors


Time Limit: 2 Seconds     
Memory Limit: 65536 KB
Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.

Input



The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:



x1 x2 c



x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output



Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.

Sample Input



5

0 4 4

0 3 1

3 4 2

0 2 2

0 2 3

4

0 1 1

3 4 1

1 3 2

1 3 1

6

0 1 0

1 2 1

2 3 1

1 2 0

2 3 0

1 2 1

Sample Output



1 1

2 1

3 1

1 1

0 2

1 1


Author: Standlove

Source: ZOJ Monthly, May 2003





题意:在一条长度为8000的线段上染色,每次把区间[a,b]染成c颜色。

显然,后面染上去的颜色会覆盖掉之前的颜色。求染完之后,每种颜色在线段上有多少个间断的区间。

线段树Lazy区间改动。

让我无语的是——输出要求是按颜色编号从0到8000输出的。

而我傻傻的按插入顺序输出了1个小时。。

。o(╯□╰)o



AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 8000+10
using namespace std;
int color[MAXN<<2];//对节点染色
void PushDown(int o)
{
if(color[o] != -1)
{
color[o<<1] = color[o<<1|1] = color[o];
color[o] = -1;
}
}
void update(int o, int l, int r, int L, int R, int v)
{
if(L <= l && R >= r)
{
color[o] = v;
return ;
}
PushDown(o);
int mid = (l + r) >> 1;
if(L <= mid)
update(o<<1, l, mid, L, R, v);
if(R > mid)
update(o<<1|1, mid+1, r, L, R, v);
}
int rec[MAXN];//存储i节点的颜色
int top = 0;
void query(int o, int l, int r)
{
if(l == r)
{
rec[top++] = color[o];//记录节点的颜色
return ;
}
int mid = (l + r) >> 1;
PushDown(o);
query(o<<1, l, mid);
query(o<<1|1, mid+1, r);
}
int num[MAXN];//记录颜色出现的 段数
int main()
{
int N;
while(scanf("%d", &N) != EOF)
{
memset(color, -1, sizeof(color));
int a, b, c;
for(int i = 1; i <= N; i++)
{
scanf("%d%d%d", &a, &b, &c);
update(1, 1, 8000, a+1, b, c);//相应颜色数 先加一
}
memset(rec, -1, sizeof(rec));
top = 0;//初始化
query(1, 1, 8000);
memset(num, 0, sizeof(num));//初始化
int i, j;
for(i = 0; i < top;)
{
if(rec[i] == -1)
{
i++;
continue;
}
num[rec[i]]++;
for(j = i + 1; j < top; j++)
{
if(rec[j] != rec[i] || rec[j] == -1)
break;
}
i = j;
}
for(int i = 0; i <= 8000; i++)
{
if(num[i])
printf("%d %d\n", i, num[i]);
}
printf("\n");
}
return 0;
}

直接模拟也能够过:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN (10000+10)
#define MAXM (50000000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int num[MAXN];
int color[MAXN];
int main()
{
int n;
while(Ri(n) != EOF)
{
int Max = -INF;
CLR(color, -1);
for(int i = 0; i < n; i++)
{
int x, y, c;
Ri(x); Ri(y); Ri(c);
Max = max(Max, c);
for(int j = x; j < y; j++)
color[j] = c;
}
CLR(num, 0);
for(int i = 0; i <= 8000; )
{
int temp = color[i];
if(temp == -1)
{
i++;
continue;
}
i++;
while(temp == color[i])
i++;
num[temp]++;
}
for(int i = 0; i <= Max; i++)
if(num[i])
printf("%d %d\n", i, num[i]);
printf("\n");
}
return 0;
}

zoj 1610 Count the Colors 【区间覆盖 求染色段】的更多相关文章

  1. ZOJ 1610 Count the Colors&lpar;区间染色&rpar;

    题目大意:多组数据,每组给一个n(1=<n<=8000),下面有n行,每行有l,r,color(1=<color<=8000),表示将l~r颜色变为color,最后求各种颜色( ...

  2. ZOJ 1610 Count the Colors (线段树 成段更新)

    题目链接 题意:成段染色,初始为0,每次改变一个区间的颜色,求最后每种颜色分别有多少段.颜色按照从 小到大输出. 分析:改变了代码的风格,因为看了学长的博客.直接用数组,可以只是记录节点的编号,因为节 ...

  3. ZOJ 1610 Count the Colors【题意&plus;线段树区间更新&amp&semi;&amp&semi;单点查询】

    任意门:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1610 Count the Colors Time Limit: 2 ...

  4. ZOJ 1610——Count the Colors——————【线段树区间替换、求不同颜色区间段数】

    Count the Colors Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Subm ...

  5. ZOJ 1610 Count the Colors&lpar;线段树&comma;区间覆盖&comma;单点查询&rpar;

    Count the Colors Time Limit: 2 Seconds      Memory Limit: 65536 KB Painting some colored segments on ...

  6. ZOJ - 1610 Count the Colors(线段树区间更新,单点查询)

    1.给了每条线段的颜色,存在颜色覆盖,求表面上能够看到的颜色种类以及每种颜色的段数. 2.线段树区间更新,单点查询. 但是有点细节,比如: 输入: 2 0 1 1 2 3 1 输出: 1 2 这种情况 ...

  7. ZOJ 1610 Count the Colors (线段树区间更新)

    题目链接 题意 : 一根木棍,长8000,然后分别在不同的区间涂上不同的颜色,问你最后能够看到多少颜色,然后每个颜色有多少段,颜色大小从头到尾输出. 思路 :线段树区间更新一下,然后标记一下,最后从头 ...

  8. zoj 1610 Count the Colors 线段树区间更新&sol;暴力

    Count the Colors Time Limit: 1 Sec  Memory Limit: 256 MB 题目连接 http://acm.zju.edu.cn/onlinejudge/show ...

  9. zoj 1610 Count the Colors

    http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=610  Count the Colors Time Limit:2000MS   ...

随机推荐

  1. 【转载】 ionic 的 下拉刷新 与 上拉加载

    这篇文章是讲解 Ioinc中怎么实现 下拉刷新和上拉加载的.也是我们日常做项目是必不可少的功能.有兴趣的小伙伴可以来学习一下. 更多关于 IONIC 的资源: http://www.aliyue.ne ...

  2. MinStack

    Design a stack that supports push, pop, top, and retrieving the minimum element in constant time. pu ...

  3. 调用微信退款接口时出现System&period;Security&period;Cryptography&period;CryptographicException&colon; 出现了内部错误 解决办法

    我总结了一下出现证书无法加载的原因有以下三个 1.证书密码不正确,微信证书密码就是商户号 解决办法:请检查证书密码是不是和商户号一致 2.IIS设置错误,未加载用户配置文件 解决办法:找到网站使用的应 ...

  4. Amazium源码分析:&lpar;1&rpar;基本介绍

    前言 Amazium是一个网格系统的框架,分析该源码的目的是了解网格系统的实现. 网格系统 定义:设计美观页面布局的方式,上图能够很直观的了解什么是网格系统. 基本概念 column: 列. gutt ...

  5. 基于linux 的2048

    在 debian 下写了一个 2048, 效果如下: 感兴趣的朋友可以在这里(http://download.csdn.net/download/kamsau/7330933)下载. 版权声明:本文为 ...

  6. 系统监控、诊断工具之top

    大家对top 命令可能不会陌生,它的作用主要用来监控系统实时负载率.进程的资源占用率及其它各项系统状态属性是否正常. top命令的截图如下: (1)系统.任务统计信息: 前8行是系统整体的统计信息.第 ...

  7. C - Catch That Cow

    题目大意 农民约翰需要抓住他的牛,他和他的牛在一条直线上(估计是一维生物),约翰在NN; ; ; i<; i++)        {            )                q- ...

  8. 龙邱STM32单片机用J-LINK下载无法被识别的解决方法

    问题如下: 按照正常步骤使用keil5给龙邱的stm32下载程序,SWD下载方式提示no cortex-m sw device found,JTAG方式提示no cortex-m device fou ...

  9. JDBC的使用流程

    //导入包: import java.sql.*; //注册JDBC驱动程序: Class.forName("com.mysql.jdbc.Driver"); //打开一个连接: ...

  10. RxJava&lpar;10-操作符原理&amp&semi;自定义操作符&rpar;

    转载请标明出处: http://blog.csdn.net/xmxkf/article/details/51791120 本文出自:[openXu的博客] 目录: 自定义创建操作符 数据序列操作符li ...