zoj The 12th Zhejiang Provincial Collegiate Programming Contest Capture the Flag

时间:2024-01-12 09:41:14

http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5503

The 12th Zhejiang Provincial Collegiate Programming Contest - K
Capture the Flag

Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge

In computer security, Capture the Flag (CTF) is a computer security competition. CTF contests are usually designed to serve as an educational exercise to give participants experience in securing a machine, as well as conducting and reacting to the sort of attacks found in the real world. Reverse-engineering, network sniffing, protocol analysis, system administration, programming, and cryptanalysis are all skills which have been required by prior CTF contests at DEF CON. There are two main styles of capture the flag competitions: attack/defense and jeopardy.

In an attack/defense style competition, each team is given a machine (or a small network) to defend on an isolated network. Teams are scored on both their success in defending their assigned machine and on their success in attacking other team's machines. Depending on the nature of the particular CTF game, teams may either be attempting to take an opponent's flag from their machine or teams may be attempting to plant their own flag on their opponent's machine.

Recently, an attack/defense style competition called MCTF held by Marjar University is coming, and there are N teams which participate in the competition. In the beginning, each team has S points as initial score; during the competition, there are some checkpoints which will renew scores for all teams. The rules of the competition are as follows:

  • If a team has been attacked for a service P, they will lose N - 1 points. The lost points will be split equally and be added to the team(s) which attacks successfully. For example, there are 4 teams and Team A has been attacked by Team B and Team C, so Team A will lose 3 points, while Team B and Team C each will get 1.5 points.
  • If a team cannot maintain their service well, they will lose N - 1 points, which will be split equally too and be added to the team(s) which maintains the service well.

The score will be calculated at the checkpoints and then all attacks will be re-calculated. Edward is the organizer of the competition and he needs to write a program to display the scoreboard so the teams can see their scores instantly. But he doesn't know how to write. Please help him!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains four integers N (2 <= N <= 100) - the number of teams, Q - the number of services (1 <= Q <= 10), S - the initial points (0 <= S <= 100000) and C - the number of checkpoints (1 <= C <= 100).

For each checkpoint, there are several parts:

  • The first line contains an integer A - the number of the successful attacks. Then A lines follow and each line contains a message:
    [The No. of the attacker] [The No. of the defender] [The No. of the service]

    For example, "1 2 3" means the 1st team attacks the 2nd team in service 3 successfully. The No. of teams and services are indexed from 1. You should notice that duplicate messages are invalid because of the rules. Just ignore them.

  • Then there are Q lines and each line contains N integers. The jth number of the ith line indicating the jth team's maintaining status of the ith service, where 1 means well and 0 means not well.
  • Finally there is an integer U (0 <= U <= 100), which describing the number of the queries. The following line contains U integers, which means Edward wants to know the score and the ranking of these teams.

Output

For each query L, output the score and the ranking of the Lth team. The relative error or absolute error of the score should be less than 10-5. The team with higher score gets higher rank; the teams with the same scores should have the same rank. It is guaranteed that the scores of any two teams are either the same or with a difference greater than 10-5.

Sample Input

1
4 2 2500 5
0
1 1 1 1
1 1 1 1
4
1 2 3 4
2
1 2 1
3 2 1
1 1 1 1
1 1 1 1
4
1 2 3 4
1
1 2 2
1 1 1 1
1 1 1 0
4
1 2 3 4
0
0 0 0 0
0 0 0 0
4
1 2 3 4
0
1 1 1 1
1 1 1 1
2
1 4

Sample Output

2500.00000000 1
2500.00000000 1
2500.00000000 1
2500.00000000 1
2501.50000000 1
2497.00000000 4
2501.50000000 1
2500.00000000 3
2505.50000000 1
2495.00000000 4
2502.50000000 2
2497.00000000 3
2499.50000000 1
2489.00000000 4
2496.50000000 2
2491.00000000 3
2499.50000000 1
2491.00000000 3

Hint

For C++ users, kindly use scanf to avoid TLE for huge inputs.

分析:

先输入4个数,n,q,p,c

代表有n个队伍,q个服务器,每支队伍的初始分数p,还有c次操作

对于每次操作,首先输入一个k,代表k次攻击

每次攻击有三个数,a,b,c,代表a通过c服务器成功的攻击了b

对于每次成功的攻击,b会失去n-1分,这n-1分会平分给通过同一服务器攻击b的几支队伍

然后是q行,每行n个数,分别代表1~n是否成功维护了,1为成功,0为不成功

不成功的队伍会失去n-1分,这失去的分会平分给成功维护的那些队伍

然后输入k个数,询问这k支队伍的分数

AC代码:

 #include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define ls 2*i
#define rs 2*i+1
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,x) memset(a,x,sizeof(a))
#define w(a) while(a)
#define LL long long
const double pi = acos(-1.0);
#define Len 20005
#define mod 19999997
#define exp 1e-5
const int INF = 0x3f3f3f3f; struct node
{
int id,rank;
double score;
} a[]; int n,q,c,t;
double p;
bool vis[][][],hsh[]; int cmp1(node a,node b)
{
return a.score>b.score;
} int cmp2(node a,node b)
{
return a.id<b.id;
} int main()
{
int i,j,k;
scanf("%d",&t);
w(t--)
{
scanf("%d%d%lf%d",&n,&q,&p,&c);
up(i,,n)
{
a[i].id = i;
a[i].rank = ;
a[i].score = p;
}
w(c--)
{
scanf("%d",&k);
mem(vis,false);
w(k--)
{
int atk,def,sev;
scanf("%d%d%d",&atk,&def,&sev);
if(vis[atk][def][sev]) continue;
vis[atk][def][sev] = true;
}
up(i,,q)//服务器
{
up(j,,n)//防守方
{
int cnt = ;
up(k,,n)//攻击方
{
if(vis[k][j][i])//统计攻击j的队伍有几支
cnt++;
}
if(!cnt)
continue;
double ss = 1.0*(n-)/cnt;//平分
a[j].score-=(n-);//防守方失去n-1
up(k,,n)
{
if(vis[k][j][i])//攻击方得到分数
a[k].score+=ss;
}
}
} up(i,,q)//服务器
{
mem(hsh,false);
int cnt = ;
up(j,,n)
{
int x;
scanf("%d",&x);
if(x)//成功维护的队伍数
{
hsh[j] = true;
cnt++;
}
else
{
hsh[j] = false;
a[j].score-=(n-);
}
}
if(cnt == n) continue;
double ss = 1.0*(n-)/cnt;
ss = ss*(n-cnt);
up(j,,n)
{
if(hsh[j])
a[j].score+=ss;
}
} sort(a+,a+n+,cmp1);
up(i,,n)//更新排名
{
if(i!=)
{
if(fabs(a[i].score-a[i-].score)<exp)
a[i].rank = a[i-].rank;
else
a[i].rank = i;
}
else
a[i].rank = i;
}
sort(a+,a+n+,cmp2);
scanf("%d",&k);
w(k--)
{
int x;
scanf("%d",&x);
printf("%f %d\n",a[x].score,a[x].rank);
}
}
} return ;
}

最后附一张 board :

zoj The 12th Zhejiang Provincial Collegiate Programming Contest Capture the Flag

http://paste.ubuntu.com.cn/i2563575

浙大霸气!!!杭电威武!!!

任性啊,,,