HDU1088 Write a simple HTML Browser【字符串处理】【水题】

时间:2023-01-04 17:29:45
Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8533    Accepted Submission(s): 2402
Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed. 
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do? 
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 
Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines. 
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 
Output
You should display the the resulting text using this rules: 
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line. 
  . If you read a <br> in the input, start a new line. 
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again). 
The last line is ended by a newline character.

Sample Input
Hallo, dies ist eine 
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines. 
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung       mehrere Leerzeichen irritieren

Html genauso wenig wie


mehrere Leerzeilen.
 
Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei

produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.
 
Source

University of Ulm Local Contest 1999


题目大意:输入一段HTML的文本,然后根据输入的文本,按照HTML的语言格式输出

出来,但是每一行不能超出80个字符,超出的就要换行输出。

注:遇到<br>就要换行,遇到<hr>就要在下一行输入80个'-'。

思路:第一遍做的时候边读入边输出,刚开始PE了两次,改了改AC了。之后觉得这样

输入输出毫无审美可言。。。所以改成了先存入一个大的字符串中,再将它输出出来。

这样就美观多了。(ーー゛)。。。

第一遍边输入边输出:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

char s[110];

int main()
{
int Count = 0;
while(cin >> s)
{
if(strcmp(s,"<br>") == 0)
{
cout << endl;
Count = 0;
continue;
}
if(strcmp(s,"<hr>") == 0)
{
if(Count > 0)
{
Count = 0;
cout << endl;
}

for(int i = 0; i < 80; ++i)
cout << '-';
cout << endl;
continue;
}
int len = strlen(s);
Count += len;
if(Count + 1 > 80)
{
Count = len;
cout << endl << s;
}
else
{
if(Count > len)
cout << ' ';
cout << s;
Count++;
}
}
cout << endl;
return 0;
}

第二遍先输入存储再输出:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

char s[110];
char a[10010];
int main()
{
int Count = 0;
int id = 0;
while(cin >> s)
{
if(strcmp(s,"<br>") == 0)
{
a[id++] = '\n';
Count = 0;
continue;
}
if(strcmp(s,"<hr>") == 0)
{
if(Count > 0)
{
Count = 0;
a[id++] = '\n';
}
for(int i = 0; i < 80; ++i)
a[id++] = '-';
a[id++] = '\n';
continue;
}
int len = strlen(s);
Count += len;
if(Count + 1 > 80)
{
Count = len;
a[id++] = '\n';
for(int i = 0; i < len; i++)
a[id++] = s[i];
}
else
{
if(Count > len)
a[id++] = ' ';
for(int i = 0; i < len; ++i)
a[id++] = s[i];
Count++;
}
}
a[id] = 0;
cout << a << endl;
return 0;
}